SDDM fails to start on bootup despite being enabled


I’ve just installed Fedora Server Edition in a VM, and I’ve found that sddm refuses to start automatically on boot, bringing me to a tty, despite sddm.service being enabled.
Restarting sddm.service starts sddm correctly.
Output of systemctl status sddm upon boot:

        ○ sddm.service - Simple Desktop Display Manager
             Loaded: loaded (/usr/lib/systemd/system/sddm.service; enabled; preset: enabled)
            Drop-In: /usr/lib/systemd/system/service.d
             Active: inactive (dead)
               Docs: man:sddm(1)

Hello @imperatorstorm ,
Server is not really set up to have a GUI desktop. It is usually setup headless in most cases I think, so people tend to ssh into them to do stuff. To get the GUI you would have to make sure the correct packages are installed and the startx I guess.

1 Like

You also need to enable if you have not already done so.


That worked, thanks!

I have the same issue on Fedora Kinoite. Should I apply this fix too?