Can't launch my Desktop Environment after switching login managers

Hi, I’ve been using Fedora 37 with GNOME, and I wanted to switch to KDE. I switched DEs with no hiccups, but the display manager was still GDM.
Since sddm came with KDE I tried to use systemctl to switch display managers. When the first few things I tried didn’t work, I foolishly decided to uninstall GDM. Somehow, that caused my computer to shut down, and restart in the command line.
I tried several things to get back into my desktop environment, such as restoring a timeshift snapshot (which I couldn’t get to work), launching sddm using the command, which made me restart, and even reinstalling GDM, which yielded similar results.

I’m currently on a live Manjaro instance running off of a USB. I tried launching timeshift, but none of my snapshots were located. Any advice on how to repair my Fedora installation would be greatly appreciated, and, of course, I would be happy to give more information if it is required :slight_smile:

Go back to the comandline and log you in there.
It seams you deactivated gdm and not activated sddm:

systemctl disable gdm
systemctl enable sddm

You can any time check how the status is with
systemctl status "LOGINMANAGER" (replace login-manager with yours you want to use)

This shows you also the errors if you have some.

And probably with dnf right? DNF removes you also dependencies. Now y ou might have missing packages you still need to run gnome-shell. So if you really just want to remove a package you should use rpm.

This worked. Thanks!