Screen Tearing on widescreen monitor

Hi! I have just done a fresh install of Fedora 31 KDE Plasma as I just moved from Windows and am a complete linux noob. I noticed that on my widescreen monitor there is an abundant amount of screen tearing if I set the resolution to 2560x1080. It flickers through a bunch of different colours and gets intense if I move the mouse. When i set the resolution to 1920x1080 the flicker goes down a lot but is still there.

I have tried changing the compositor to Full screen repaints but that doesn’t fix the issue. On researching I found it could be my graphics driver. I have no clue how to swap to the amdgpu module to test.

Output of lspci -k | grep -EA3 'VGA|3D|Display'

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
Subsystem: Gigabyte Technology Co., Ltd Device d000
Kernel driver in use: i915
Kernel modules: i915

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390] (rev 80)
Subsystem: ASUSTeK Computer Inc. STRIX R9 390
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu

you would need the intel driverson x86 it looks like you are using the drivers for the wrong arcitecher and AMD too, I have no idea how to help but I hope it helps

Try Gnome3. It uses Wayland by default. Wayland’s devs promised that we all will forget the troubles your mentioning for good.

this implyes the wrong driver tho

Why? It is mean dual graphics. Each device has its own drivers. Intel integrated has i915 (it is a fresh install, it is rather not a mistake). AMD uses radeon (why not amdgpu, though?).

1 Like

I under the driver’s are incorrect how would I go about swapping them to current drivers? Would I use the modprobe command??

Kernel rejects wrong drivers. Try log in the Wayland session. Only take on the harder topic about the drivers if this didn’t helps.

or try to use the gnome-3 DE on wayland

1 Like

I tried a live cd of gnome before doing the install of kde and the issue was there aswell. Not to a great extent but enough to hurt the eyes

in the kde settings there is a option to change aspect ratio this may help?

sorry resolution setting insted

you could also try updateing your system with sudo dnf update

Like I said when I change the resolution from 2560x1080 to 1920x1080 the issue goes down but isn’t completely gone. With the side note of the screen looking stretched as it as a 2560x1080 monitor

Sudo dnf update returns all dependencies are up to date. Will attempt to use modprobe to load the correct drivers and report back if the issue is fixed

Arch Wiki (better see a post below)

link to beginning.

"Simply add module_blacklist=modname1,modname2,modname3 to your bootloader’s kernel line, as described in Kernel parameters.

Note: When you are blacklisting more than one module, note that they are separated by commas only. Spaces or anything else might presumably break the syntax."

Try to blacklist radeon.


Just try disable radeon driver and take up the amdgpu:

You can do a temporary test setting these boot parameters in the kernel:

You do temporay changes in the boot kernels parameter read it

radeon.cik_support=0 radeon.si_support=0 amdgpu.cik_support=1 amdgpu.si_support=1

Note with it you will disable the radeon driver for your card in the boot process

After if it didn’t work disable compositor v-sync in KDE compositor by selecting (never)

If this did work, do the changes permanent to the next reboots:

A) with grubby

B) with grub2-mkconfig

  • you will need first edit your file etc/default/grub.conf and add the parameter

  • After you will regenerate the grub with

if UEFI system: sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
if BIOS system: sudo grub2-mkconfig -o /boot/grub2/grub.cfg

You know more about if you use BIOS or UEFI just check it with lsbk if you see a efi partition you are in UEFI if you see BIOS you are bios also you can check through it

Some referens about your issue.

  • amdgpu parm (here you will find all parameters that the driver amdgpu can take):

the method that did indicate @vits95 also should work but the command in the boot parameter in fedora should be if i am not wrong rd.driver.blacklist=<module> and you would generate a blacklist.conf file and regenerate your initramfs (initrd) Referens below:



The moment I switched from the radeon to amdgpu driver the tearing stopped completely. Thank you so much!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.