Horizontal "Tearing" or "Glitching" on Desktop in every major Distro (incl. Fedora 38) - Dual Monitor

Hello there, (sry for my english - my native language is german)

i’m a noob to this Forum and searched a lot about my problem on the internets, like 2 weeks now, but since i’m not sure about the real reasons behind it, it’s really difficult, and I’m running out of mental energy at this point.


I run a dual monitor setup, AMD gpu (all specs in the inxi output), Fedora 38, so Gnome 44.5 (Mutter, Wayland).
In the video you can see the Problem, every time there is a mouse interaction with specific GUI Elements, horizontal “Glitches (Tearing?)” appears on both screens.

The Effect appears a lot more when windows overlap (hover above each other). But also when Apps are full-screen.
Sometimes I can work like normal, it seems to stabilize over time, but certain things are starting it again.
Yesterday I did some more stress-testing with Apps, hovering more of them above each other, and suddenly both screens turned black (missing signal) and the fans of my PC got louder. Only Solution was to hardware-restart.

Things i tried or think are worth mentioning:

  • I tried Debian, Debian Testing, EndeavorOS, ArctixArch, Ubuntu, Fedora 38 all with the same problem.
  • it appeared on Gnome 44, 44.5, Gnome with X11(Xorg), Regolith-Desktop (i3wm), Qtile, Awesome, Plasma, Plasma with X11.
  • different Kernels in these Distros let me guess that the Kernel is not the problem.
  • in the inxi-output the driver for my Radeon R390X is set to “radeon” not “amdGPU”.
    the refreshrate of one monitor is set as 59.95hz, in windows (everything works fine and stable here) the Monitor is set to 60 hz.
  • I tried many hours to change the set a custom refreshrate (so that both monitors run at the same hz) but could not find a way to do this in Mutter (also read that this is not meant to be done in Mutter)
  • I switched the inputs (DP, HDMI) of both monitors - no effect.
  • maybe the mouse is the problem (different refresh rate then monitors?)
  • it was not possible to record the “glitch” with a screen recording Software, the “Tearing” appeared on my screen, but they were not present in the video at all when watching it afterwards.

Inxi-output is from Fedora 38:

  Kernel: 6.4.15-200.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-9.fc38 clocksource: tsc Desktop: GNOME v: 44.5 tk: GTK v: 3.24.38
    wm: gnome-shell dm: GDM v: 44.1 Distro: Fedora release 38 (Thirty Eight)
  Type: Desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 3805
    date: 05/16/2018
  Info: quad core model: Intel Core i7-6700K bits: 64 type: MT MCP
    smt: enabled arch: Skylake-S rev: 3 cache: L1: 256 KiB L2: 1024 KiB
    L3: 8 MiB
  Speed (MHz): avg: 4059 high: 4175 min/max: 800/4200 cores: 1: 4000 2: 4000
    3: 4175 4: 4000 5: 4127 6: 4000 7: 4174 8: 4000 bogomips: 63999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: AMD Hawaii XT / Grenada [Radeon R9 290X/390X]
    vendor: Micro-Star MSI driver: radeon v: kernel arch: GCN-2 pcie:
    speed: 8 GT/s lanes: 16 ports: active: DP-1,HDMI-A-1
    empty: DVI-D-1,DVI-D-2 bus-ID: 01:00.0 chip-ID: 1002:67b0 class-ID: 0300
    temp: 63.0 C
  Device-2: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-1:2 chip-ID: 046d:085c
    class-ID: 0102 serial: <filter>
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: gpu: radeon display-ID: 0
  Monitor-1: DP-1 model: Asus BE24A serial: <filter> res: 1920x1200 dpi: 94
    size: 518x324mm (20.39x12.76") diag: 611mm (24.1") modes: max: 1920x1200
    min: 640x480
  Monitor-2: HDMI-A-1 model: AOC 2460G4 serial: <filter> res: 1920x1080
    dpi: 92 size: 531x299mm (20.91x11.77") diag: 609mm (24") modes:
    max: 1920x1080 min: 720x400
  API: OpenGL v: 4.5 Mesa 23.1.7 renderer: HAWAII ( LLVM 16.0.6 DRM 2.50
    6.4.15-200.fc38.x86_64) direct-render: Yes
  Device-1: AMD Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aac8 class-ID: 0403
  Device-2: Creative Labs CA0132 Sound Core3D [Sound Blaster Recon3D /
    Z-Series BlasterX AE-5 Plus] driver: snd_hda_intel v: kernel pcie:
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 1102:0012 class-ID: 0403
  Device-3: SteelSeries ApS Arctis 1 Wireless
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 bus-ID: 1-11:6 chip-ID: 1038:12b3 class-ID: 0300
  Device-4: Logitech Logitech Stereo H650e
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 bus-ID: 1-14:8 chip-ID: 046d:0a46 class-ID: 0300 serial: <filter>
  Device-5: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-1:2 chip-ID: 046d:085c
    class-ID: 0102 serial: <filter>
  API: ALSA v: k6.4.15-200.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.80 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.39 TiB used: 27.43 GiB (1.9%)
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB
    speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb vendor: Crucial model: CT500MX200SSD1 size: 465.76 GiB
    speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: MU02 scheme: GPT
  ID-3: /dev/sdc vendor: SanDisk model: Cruzer Blade size: 29.82 GiB
    type: USB rev: 2.0 spd: 480 Mb/s lanes: 1 tech: N/A serial: <filter>
    fw-rev: 1.26 scheme: GPT
  ID-1: / size: 68.35 GiB used: 17.46 GiB (25.5%) fs: ext4 dev: /dev/sdb3
  ID-2: /boot size: 973.4 MiB used: 272 MiB (27.9%) fs: ext4 dev: /dev/sdb2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/sdb1
  ID-4: /home size: 386.92 GiB used: 9.69 GiB (2.5%) fs: ext4 dev: /dev/sdb4
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 44.0 C mobo: N/A gpu: radeon temp: 63.0 C
  Fan Speeds (rpm): N/A
  Packages: pm: rpm pkgs: N/A note: see --rpm pm: flatpak pkgs: 16
  No active dnf repos in: /etc/dnf/dnf.conf
  Active yum repos in: /etc/yum.repos.d/1password.repo
    1: 1password ~ https://downloads.1password.com/linux/rpm/stable/$basearch
  Active yum repos in: /etc/yum.repos.d/_copr:copr.fedorainfracloud.org:phracek:PyCharm.repo
    1: copr:copr.fedorainfracloud.org:phracek:PyCharm ~ https://download.copr.fedorainfracloud.org/results/phracek/PyCharm/fedora-$releasever-$basearch/
  Active yum repos in: /etc/yum.repos.d/_copr:copr.fedorainfracloud.org:rockowitz:ddcutil.repo
    1: copr:copr.fedorainfracloud.org:rockowitz:ddcutil ~ https://download.copr.fedorainfracloud.org/results/rockowitz/ddcutil/fedora-$releasever-$basearch/
  Active yum repos in: /etc/yum.repos.d/docker-ce.repo
    1: docker-ce-stable ~ https://download.docker.com/linux/fedora/$releasever/$basearch/stable
  Active yum repos in: /etc/yum.repos.d/fedora-cisco-openh264.repo
    1: fedora-cisco-openh264 ~ https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-$releasever&arch=$basearch
  No active yum repos in: /etc/yum.repos.d/fedora-modular.repo
  No active yum repos in: /etc/yum.repos.d/fedora-updates-modular.repo
  No active yum repos in: /etc/yum.repos.d/fedora-updates-testing-modular.repo
  No active yum repos in: /etc/yum.repos.d/fedora-updates-testing.repo
  Active yum repos in: /etc/yum.repos.d/fedora-updates.repo
    1: updates ~ https://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/fedora.repo
    1: fedora ~ https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/google-chrome.repo
    1: google-chrome ~ https://dl.google.com/linux/chrome/rpm/stable/x86_64
  Active yum repos in: /etc/yum.repos.d/rpmfusion-free-tainted.repo
    1: rpmfusion-free-tainted ~ https://mirrors.rpmfusion.org/metalink?repo=free-fedora-tainted-$releasever&arch=$basearch
  No active yum repos in: /etc/yum.repos.d/rpmfusion-free-updates-testing.repo
  Active yum repos in: /etc/yum.repos.d/rpmfusion-free-updates.repo
    1: rpmfusion-free-updates ~ https://mirrors.rpmfusion.org/metalink?repo=free-fedora-updates-released-$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/rpmfusion-free.repo
    1: rpmfusion-free ~ https://mirrors.rpmfusion.org/metalink?repo=free-fedora-$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/rpmfusion-nonfree-nvidia-driver.repo
    1: rpmfusion-nonfree-nvidia-driver ~ https://mirrors.rpmfusion.org/metalink?repo=nonfree-fedora-nvidia-driver-$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/rpmfusion-nonfree-steam.repo
    1: rpmfusion-nonfree-steam ~ https://mirrors.rpmfusion.org/metalink?repo=nonfree-fedora-steam-$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/rpmfusion-nonfree-tainted.repo
    1: rpmfusion-nonfree-tainted ~ https://mirrors.rpmfusion.org/metalink?repo=nonfree-fedora-tainted-$releasever&arch=$basearch
  No active yum repos in: /etc/yum.repos.d/rpmfusion-nonfree-updates-testing.repo
  Active yum repos in: /etc/yum.repos.d/rpmfusion-nonfree-updates.repo
    1: rpmfusion-nonfree-updates ~ https://mirrors.rpmfusion.org/metalink?repo=nonfree-fedora-updates-released-$releasever&arch=$basearch
  Active yum repos in: /etc/yum.repos.d/rpmfusion-nonfree.repo
    1: rpmfusion-nonfree ~ https://mirrors.rpmfusion.org/metalink?repo=nonfree-fedora-$releasever&arch=$basearch
  Processes: 321 Uptime: 2h 31m wakeups: 0 Memory: total: 16 GiB
  available: 15.55 GiB used: 5.17 GiB (33.3%) Init: systemd v: 253
  target: graphical (5) default: graphical Compilers: gcc: 13.2.1 Shell: Bash
  v: 5.2.15 running-in: gnome-terminal inxi: 3.3.29

xrandr -q output:

Screen 0: minimum 16 x 16, current 3840 x 1200, maximum 32767 x 32767
XWAYLAND0 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 520mm x 320mm
   1920x1200     59.88*+
   1600x1200     59.87  
   1440x1080     59.87  
   1400x1050     59.86  
   1280x1024     59.76  
   1280x960      59.94  
   1152x864      59.78  
   1024x768      59.68  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1680x1050     59.85  
   1440x900      59.89  
   1280x800      59.81  
   720x480       59.71  
   640x400       59.20  
   320x200       58.96  
   1920x1080     59.88  
   1600x900      59.82  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.45  
   720x400       59.55  
   640x350       59.77  
XWAYLAND1 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 530mm x 300mm
   1920x1080     59.96*+
   1440x1080     59.99  
   1400x1050     59.98  
   1280x1024     59.89  
   1280x960      59.94  
   1152x864      59.96  
   1024x768      59.92  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1680x1050     59.95  
   1440x900      59.89  
   1280x800      59.81  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1600x900      59.95  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  

I’m trying to set up a stable Linux Environment for Coding, would love to use Linux, but at the moment it seems like a very frustrating experience, hope somebody can help. Thanks in advance and let me know if you need more infos!

Seems I have resolved the Problem.

I changed the used Graphics-Card drivers from “radeon” to “amdgpu”:

sudo gedit /etc/default/grub

added these lines to the file:

GRUB_CMDLINE_LINUX_DEFAULT="radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 amdgpu.dc=1 amdgpu.dpm=1 amdgpu.modeset=1"

and then updated the grub.cfg by:

sudo grub2-mkconfig -o /etc/grub2.cfg

sudo grub2-mkconfig -o /etc/grub2-efi.cfg 

Then do a reboot.

Finally! Hope this helps others in the future. Good Luck.

Use the Linux Hardware Database Radeon R9 290x/390X. There are 22 scans for your GPU. If you look at one of the scans you get a list of available drivers for various kernel versions. In addition to radeon, amdgpu is listed (also fglrx, but the Fedora copr repo says “dead package” 10 years ago).

Wikipedia’s Table of AMD GPU capabilities puts the 300 in a gap before AMD support for linux and after Linux drm/radeon support ends and drm/amdgpu support begins. Arch linux of often has excellent documentation, so you might look at Arch Linux Xorg on AMD.

You might have a better experience with a more recent GPU.


Glad you got it working. Did you come to this by trial and error by finding a reference that gives the command-line options? If the latter, it would be good to include a link. It may also help others if you upload a Linux Hardware Probe for your system.

Sure, there were several sites that helped me getting there, i had to combine them because there were outdated commands for grub, so better use the commands I posted or look them up by yourself (especially when this post here gets old by the time):