Dual AMD/NVIDIA GPU - xorg-x11-drv-nouveau System Error


So I am very very new to Linux, I have made the plunge and made f36 my daily driver for work and gaming.

I am running f36 on an Asus ROG Zephyrus G14 GA401IH_GA401IH. It runs a dual GPU: here is an my neofetch return:

AMD Ryzen 7 4800HS with Radeon Graphics (16) @ 2.900GHz 
GPU: NVIDIA 01:00.0 NVIDIA Corporation TU117M 
GPU: AMD ATI 04:00.0 Renoir

I had issues getting the Nvidia drivers installed until I disabled secure boot.

Before I disabled secure boot I would get about three xorg-x11-drv-nouveau System Errors each time I turned on or restarted my system.

Since disabling secure boot I’ve only seen this error once or twice.

My question is this:
(and yes I realize that this is probably a very beginner question)
How do I make sure that Fedora is using my main Nvidia 1650 GPU for heavy tasks instead of my AMD integrated GPU.

OpenGL render is showing the AMD card if that is relevant.

(I have been going down many different rabbit trails installing reinstalling and uninstalling rpm fusion drives on different forum posts but those are all pre official Nvidia driver release)

EDIT: I have tested out Apex and can confirm that it is only running off my AMD GPU. How do I get fedora to use my Nvidia gpu.

Welcome to ask :fedora:

There are several similar threads on this forum.

In a nutshell.

  1. install the nvidia drivers from rpmfusion.
    This involves enabling the 3rd party repos from gnome software so you have the rpmfusion-nonfree-nvidia repo enabled, then installing the nvidia drivers with sudo dnf install akmod-nvidia

  2. reboot

  3. with each app you wish to use the nvidia GPU then a right click on the icon and select “use dedicated GPU” will ensure that app is running on that GPU.

  4. If you (optionally) want to have the nvidia GPU run everything then 2 additional steps are required.
    a. copy /usr/share/X11/xorg.conf.d/nvidia.conf to /etc/X11/xorg.conf.d/nvidia.conf
    b. edit the file just placed under /etc and add the line Option "PrimaryGPU" "yes" to both stanzas of that file.

A final reboot should ensure that the nvidia GPU is now used for everything.

All this info can be found at the rpmfusion howto and here. For gaming you may also wish to install cuda from rpmfusion as shown here

Thanks for the direction! That helped. I unded up uninstalling all the Nvidia stuff and starting again.

Turns out my issue was secure boot related. I could get secure boot to work and had to disable it for my Nvidia Card to work.