Screen stays black after booting into fedora

Hello guys, I have a laptop that has both an integrated intel graphics card and a dedicated Nvidia GPU and sometime ago I ran the instruction at this page, How to Set Nvidia as Primary GPU on Optimus-based Laptops :: Fedora Docs , so that I could use exclusively the Nvidia GPU, it worked great.

But today I wanted to use my integrated graphics card again because of power usage and so what I did was running the instructions at this forum page, [Solution] Easy PRIME setup using NVIDIA Auto Installer for Fedora, to activate prime so that I could choose between the two cards. And after running all the commands, no prime option appeared in the Nvidia graphics app.

So my next guess was to install envycontrol and change between the graphics cards trough that program, and so I did, I installed the program, ran it and changed my graphics card to “integrated”, and it prompted me to reboot my pc. After that reboot every time I tried to boot into fedora I just get a black screen, but the lights on my keyboard turn on and I have system sounds, so I believe that the system is actually booting ok but the screen is just black.

Any help would be appreciated.

Hi @ruicoito,

Following that option lets you set the NVIDIA card as the primary one for every purpose. It usually requires a reboot after enabling the PRIME support for having everything offloaded to the discrete GPU and after disabling the PRIME support for having everything be on the integrated one. There will be no visible PRIME option to interactively switch between the usage of two cards when the solution mentioned at [Solution] Easy PRIME setup using NVIDIA Auto Installer for Fedora is used.

Where did you install envycontrol from and what are the steps that you used to configure the said PRIME setup, which (like I mentioned before) does not happen instantly and will always require a reboot?


Hello again! Thanks for the quick response.

So for the prime setup what I did was I ran the following commands in the terminal:

$ sudo dnf install dnf-plugins-core -y
$ sudo dnf copr enable t0xic0der/nvidia-auto-installer-for-fedora -y
$ sudo dnf install nvautoinstall -y
$ sudo nvautoinstall primec

and then said yes to the following prompt:

<Y> to enable PRIME support

after that i received the message that “Prime support was successfully enabled”.

At this point no Prime configuration appeared on the Nvidia driver app and since the commands that I ran none of them said that I needed to reboot my machine I just thought that it wasn’t working. I then installed envy control using the following commands:

sudo dnf copr enable sunwire/envycontrol
sudo dnf install python3-envycontrol

after the installation finished I ran

sudo envycontrol -s integrated

and it prompted me to reboot my laptop, so I did.

After that it started to boot back up but the screen was black. I booted my pc again and the grub menu appears but once I boot into any of the fedora options the screen just stays black and I don’t know what to do next.

With PRIME support being enabled, all the framebuffer is offloaded to the discrete GPU. This essentially means that the integrated one is not used for anything and the NVIDIA GPU is used for all purposes. This, in no way, means enabling of switchable graphics if that is what you are looking for.

The default configuration of the driver should allow you to render the desktop environment using the integrated GPU while other things can be (chosen to be) rendered using the discrete GPU from the context menu of the application from the default launcher.

Please try disabling the PRIME support from the NVAUTOINSTALL application before using some other application to serve the same purpose as the configuration resulted with the use of both of these tools might cause conflicts with the actual display server - resulting in the said problem.

So yesterday I thinkered with it a bit more because I felt like what I had done was change the graphics card to the integrated one but somehow something was blocking that graphics card from ouputing image to the screen.

That is when I found out that in my bios I had the option to only use the discrete graphics card, enabled, so i changed that option to use switchable graphics instead and all of the sudden everything was working back again like intended.

Sorry for all the trouble and for my limited knowledge on the topic.

It’s all good.

Glad to know you were able to solve the issue.