Fedora 35 refuses to start without external monitor after installing Nvidia drivers

I followed the intructions (1) on how to install NVIDIA drivers on my Predator Helios 300 notebook running Fedora 35 Cinnamon. The installation was done with an external monitor connected to the notebook.

With the NVIDIA drivers installed, the notebook boots into a black screen if I do not have the external display connected . I have tried to login anyway but this does not work.

Everything works fine with the external display connected. I can remove the external display once I have logged in. This issue has been replicated on a fresh installation of Fedora 35. I do not know how to proceed. Preferably, I would not like to reinstall Fedora and redo the driver installation, without the external display.

(1) How to Set Nvidia as Primary GPU on Optimus-based Laptops :: Fedora Docs

Welcome to askfedora. We are glad to see you and hope you stick around.

From where did you install the nvidia drivers?
If you used the procedure in the info you linked then there may be a slight error in step # 9. If you set the nvidia as primary according to that step then you see the issue since by default the nvidia dGPU only operates the external monitor while the IGP handles the built-in screen. Setting the nvidia as primary without also telling it to manage the built-in screen causes the syptoms you see.

I usually suggest that the line Option "Primary" "yes" be added to both stanzas in the file /etc/X11/xorg.conf.d/nvidia.conf. That adds it to the “ServerLayout” section as well as the “OutputClass” section.

I am not 100% certain that both are required, but the ServerLayout section contains the line Option "AllowNVIDIAGPUScreens" which tells xorg to allow the nvidia GPU to allow use of both video outputs, the built in as well as the external monitors, and it seems reasonable so that is what I use.

On my laptop I have the below and have never had an issue with only having one of the screens working at any time.


1 Like

Changing nvidia.conf to match yours solved the problem.

Thank you for your help JV!

1 Like