Samsung Xpress M2070 printer driver problem

Hello, I am new to Fedora and never had to use a tar.gz file but here I am as its the only way to get that printer working. so I downloaded here Samsung Xpress SL-M2070 Laser Multifunction Printer series Software and Driver Downloads | HP® Customer Support
then unpacked it and opened terminal in the new uld Directory. There is no configure file, just various install scripts. so I should do:

sudo make install

none of the command works
I use a fresh install of the latest 30 download, then updated.
please help

Hello @mustang8888 …! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

seem you don’t need to do this:

inside the uld directory you have three script, just position in that directory in terminal and run:

sudo ./
sudo ./
sudo ./

Just follow the step…


1 Like

Thanks for the welcome. Glad to be here. sometimes the obvious allure us so, that we dont see it.
thanks. worked like a charm.:+1::+1:


I’ve been using this printer since Fedora 33 and now I’m on F36. With every new Fedora version I repeated this installation procedure and it worked like a charm. But I wonder if it will have some compatibility issues with future versions of Fedora. Because I don’t expect they will issue an updated driver if this happens. Do you have any idea how probable this scenario is?