Remote Desktop on Fedora 33

Hi there,

I am trying to use NoMachine to connect to a client. I would like to connect either through NX or SSH for remote desktop purposes.

I get this error

I am just wondering if anyone has any good remote desktop software/technology that works between well between multiple platforms (MacOSX/Windows/various linux distro’s etc)

I though perhaps my firewall is blocking this or perhaps I don’t have NX protocol enabled.

To find out if it is the network address or the protocol simply ping the IP of the remote machine. If that gives you a response then it is narrowed down to the protocol but if you do not get a ping response then you likely need to start at the network level, possibly routing.

I would guess from that IP you are working with a VM and all the pertinent details would help us to provide informed advice. Is this VM using bridging or NAT? Is the problem in communicating between host and VM or a remote VM on another host?

1 Like

Thanks a lot I’ll try that tonight and see how I go

Actually I am trying to connect remotely to another computer

I actually am a big fan of Zoho (just wish they were open source more), they have a nifty program called zoho assist which seems to be working very well.

I have tried Nomachine quite a bit although I am yet to find out why it won’t work so I’ll do some testing and let you know

Hi, unclear if you are outside their network and trying to get to that address or inside. Unclear if client means a business client or some device.

If you are outside their network, you cannot get to 192.anything on somebody else’s, it’s a local network.

Hi Bill okay thanks for explaining that, so I am trying to connect to a client computer (physical machine) who also happens be one of my business clients. Sorry for the poor explanation. The client is running Linux Mint (latest)

So I am really wanting to use nomachine.

I am logging in with zoho assist and I can get the IP address today. I just want to check the process.

I am presuming I would type into the terminal:

ip -4 addr

to get the IP address

ping “IP address here”

to know whether its the protocol I am using (in this case NX and SSH)

For my system I get the output:

[benji@localhost ~]$ ip -4 addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
inet scope host lo
valid_lft forever preferred_lft forever

3: wlp6s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
inet brd scope global dynamic noprefixroute wlp6s0
valid_lft 71966sec preferred_lft 71966sec

4: virbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
inet brd scope global virbr0
valid_lft forever preferred_lft forever

so my IP address would be

is that right?

No, as I answered you on askfedora,

192.168 is an internal network. You cannot get to it from outside their
network and they can’t get to your 192.168 from their network.

Identical IPs in this range do not resolve to the same network node.

If you want to get to a node on a private network their admin has to
set up port forwarding or a VPN.


1 Like

I see thanks for clarifying that again, so would I be correct in assuming nomachine is quite different to say anydesk or TeamViewer.

Would I need to ensure NX or SSH protocol is setup, firewall is not blocking us and/or port forwarding is setup to allow us to talk to our clients system ?

Sorry if I sound like a buffoon, I’m a mechanical engineer and networking isn’t exactly a strong point for me.

I am trying to understand this discussion in the below link as I believe it would apply in my case.

I would just love an alternative to Zoho assist as anydesk is quite glitchy on our fedora machines.

Looking at the thread you listed I suspect it is using an external server just like plexmediaserver or my irobot does to access the local machine from outside the network.

In general terms, the local machine makes a connection to a remote server with the service being provided. A remote machine is then able to have communications relayed through the remote server using the ip address provided. This is also similar to how you are able to access smart homes for video, thermostat control, door locks, etc… Since that connection is maintained from within your private LAN the router issues are handled for you.

I have not tried nomachine, zoho, or anydesk, but at one time I did allow a remote tech access using ??? (can’t remember since it has been several years and only happened once) to my machine for an issue I was having with a problem and they were able to solve it quickly. Permission had to be granted from my machine for the ISP tech to even see it. The tool was similar to teamviewer and allowed access to my linux box but I cannot recall the name.

It sounds like nomachine is similar in that the connection to the server is established from the internal network, and then a remote client is able to connect and access the desktop via the relay.

Alternatively the configuration of the router with port forwarding as also described there would be possible if your router has an external IP on the ISP side. My ISP uses a private address to connect to me so I go through double NAT to reach the internet.

1 Like

thanks a lot so the router I use is the Asus 4GAC68-U

It has port forwarding I believe and a built in VPN technology which I can setup quite easily.

So this has nothing to do with the port being blocked possibly by her or my firewall. We are both using Cinnamon DE

I use Remmina and the RDP protocol.

Also you should get the public IP address, 192.168.X it’s a local address as already said.

In my case the public IP address also changes everytime I start the remote instance so I have to download the RDP configuration file every time.

1 Like

I just realised why I may have mislead people here. I am testing this software with a VM before I connect externally, to their device, hence the 192.168. type of IP (local)

So first to get this nomachine software to talk to our office VM I got the

Please see the output below of the VM, I’m assuming the IP address is the IP4 and not IP6

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    inet scope host lo
       valid_lft forever preferred_lft forever
2: ens3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    inet brd scope global dynamic noprefixroute ens3
       valid_lft 3072sec preferred_lft 3072sec

I would love to know how to use remmina and RDP protocol.

What do we put in here: