I cant get Gnome Connections app to work at all?

im running fedora on multiple machines on the same router i wanted to use Connections app to remote desktop into the machine in the other room, i have tried everything i can think off and i cant seem to figure it out, any ideas ? help will be greatly appreciated


I tested GNOME Connections with GNOME Remote Desktop using RDP.
Both server and client run GNOME on Wayland on Fedora 38.
It works as expected, but requires an active unlocked session.

ok i tried connecting using both vnc and rdp from fedora to fedora and from a chromebook to fedora both on the same router and it failed both times something about a transport layer failed

i did not install anything besides the gnome connections app is that how you did it? or did you have to enable or install something else? i just went into the gnome sharing options in the settings menu and enabled sharing for remote desktop and remote control

from there it says the device name remote desktop access is ms-rd://fedora

i replaced the first part with rdp so rdp://fedora to connect from the second machine thru gnome connections app

i can try it again to get the exact error message if it helps, i thought it must be a firewall setting so i set both fedora machines to default firewall and then went into the gui and enabled rdp and vnc and set it to permanent

then i thought it must be the isp router so i switched both machines to my wrt router and tried again still no luck

i also tried using the private IP for the machine instead of the host name which was fedora or fedora.local, could the host name settings be the problem?

i edited my reply again srry

Try connecting by IP.

thank you it is working

i used command ip a
to find the device ip

and from gnome connections app on the second pc i connected like this rdp://