RDP Client Remmina fails to connect but GNOME Connections does

I want to connect my F39 desktop to a Windows 11 Pro server through RDP (Microsoft’s Remote Desktop Protocol). There are a couple of Windows-only programs we need to run.

Remmina doesn’t work for me. I’m new to RDP so I could be making a simple mistake. I hope someone can help.

What works:

  • RDP from an Windows 11 box to the Win 11 server.
  • GNOME Connections from my Fedora 39 desktop to the Win 11 server

What doesn’t work: Remmina from my Fedora 39 desktop.

Several sources have said Remmina is better that Connections, so I’d like to use it.

How to address the Server:

  • I named it RB.
  • The Win 11 client would accept the name RB but not rb. Odd.
  • GNOME Connections would accept RB.local (mDNS) and rb.local but not RB
  • Remmina didn’t work with RB.local, rb.local, or the raw IP address.

Remmina pops up the window that would be the desktop and says: “Cannot connect to the “RB.local” RDP server.”

I turned on debugging and got this in the window:

(DEBUG) - (rcw_map_event) - Mapping: RemminaConnectionWindow
(DEBUG) - (remmina_protocol_widget_map_event) - Calling plugin mapping function
(DEBUG) - (remmina_protocol_widget_open_connection_real) - Opening connection
(DEBUG) - (remmina_rdp_event_init) - Disable smooth scrolling is set to 0
(DEBUG) - (remmina_rdp_event_init) - Adding GDK_SMOOTH_SCROLL_MASK
(DEBUG) - (remmina_protocol_widget_open_connection_real) - Have SSH
(DEBUG) - (remmina_rdp_main) - RDP data path is /home/hugh/.var/app/org.remmina.Remmina/data/remmina/RDP
(DEBUG) - (remmina_rdp_main) - Not using system proxy settings
(DEBUG) - (remmina_rdp_tunnel_init) - Tunnel init
(DEBUG) - (remmina_protocol_widget_start_direct_tunnel) - SSH tunnel initialization…
(DEBUG) - (remmina_protocol_widget_start_direct_tunnel) - Calling remmina_public_get_server_port
(DEBUG) - (remmina_protocol_widget_start_direct_tunnel) - Calling remmina_public_get_server_port (tunnel)
(DEBUG) - (remmina_protocol_widget_start_direct_tunnel) - server: RB.local, port: 3389
(DEBUG) - (remmina_rdp_tunnel_init) - protocol_plugin_start_direct_tunnel() returned [RB.local]:3389
(DEBUG) - (remmina_rdp_tunnel_init) - Tunnel has been optionally initialized. Now connecting to RB.local:3389
(DEBUG) - (remmina_rdp_main) - gfx_h264_available: 1
(DEBUG) - (remmina_rdp_main) - Resolution set by the user: 592x440
(DEBUG) - (remmina_rdp_main) - Resolution set after workarounds: 644x480
(DEBUG) - (remmina_rdp_main) - proxy_type: (null)
(DEBUG) - (remmina_rdp_main) - proxy_username: (null)
(DEBUG) - (remmina_rdp_main) - proxy_password: (null)
(DEBUG) - (remmina_rdp_main) - proxy_hostname: (null)
(DEBUG) - (remmina_rdp_main) - proxy_port: 80
(DEBUG) - (remmina_rdp_main) - Network settings not set
(DEBUG) - (remmina_rdp_main) - rdp_keyboard_remapping_list: 
(DEBUG) - (remmina_rdp_main) - Log level set to to INFO
(DEBUG) - (rco_on_disconnect) - Disconnect signal received on RemminaProtocolWidget
(DEBUG) - (remmina_file_save) - Saving profile
(DEBUG) - (remmina_file_save) - We have a password and disablepasswordstoring=0
(DEBUG) - (remmina_file_save) - We have a password and disablepasswordstoring=0
(DEBUG) - (remmina_file_save) - We have a password and disablepasswordstoring=0
(DEBUG) - (remmina_file_save) - We have a password and disablepasswordstoring=0
(DEBUG) - (remmina_file_save) - Profile saved
(DEBUG) - (remmina_file_save) - Connection profile states saved
(DEBUG) - (remmina_network_monitor_status) - G_NETWORK_CONNECTIVITY_FULL
(DEBUG) - (rco_on_disconnect) - Could not disconnect

Please use lowercase for your system names, especially when you try to use them with different Operating Systems … as you pointed out, the names got recognized differently. Take also in consideration that RDP is a Microsoft protocol.

Please see this article and try the flatpak/rpm version too.

1 Like

Thanks for the reply.

I’m pretty sure that when I set the system name, I used lower case letters.
Settings: Home shows the name in lower case.
msinfo32 shows the name in upper case.
DNS is case-insensitive. So mDNS should be too.
I don’t know the naming system used by RDP so I cannot say if case should matter to it.

It turns out that my Fedora installation had Remmina installed as a flatpak.
I deleted that and installed “normal” packages.
Now Remmina works.
Superstitious: this is why I avoid flatpaks.

I used “rb.local” as the name (just “rb” did not work.

When I made the connection, I had to give it username, password, and domain. Not having a clue about what a domain is, I left it blank and the log-in worked.

Invoking Remmina from a terminal gives me bonus diagnostics. I don’t really know what they mean.

[11:08:55:918] [51240:52086] [ERROR][com.freerdp.common.settings] - [freerdp_settings_get_bool] Invalid key index 131
[11:08:55:918] [51240:52086] [ERROR][com.freerdp.common.settings] - [freerdp_settings_get_bool] Invalid key index 0
[11:08:55:114] [51240:52086] [WARN][com.freerdp.crypto] - Certificate verification failure 'self-signed certificate (18)' at stack position 0
[11:08:55:114] [51240:52086] [WARN][com.freerdp.crypto] - CN = redbull
[11:09:34:168] [51240:52086] [INFO][com.freerdp.gdi] - Local framebuffer format  PIXEL_FORMAT_BGRA32
[11:09:34:168] [51240:52086] [INFO][com.freerdp.gdi] - Remote framebuffer format PIXEL_FORMAT_BGRA32
[11:09:34:169] [51240:52086] [INFO][com.freerdp.channels.rdpsnd.client] - [static] Loaded fake backend for rdpsnd
[11:09:34:169] [51240:52086] [INFO][com.freerdp.channels.drdynvc.client] - Loading Dynamic Virtual Channel disp
[11:09:34:169] [51240:52086] [INFO][com.freerdp.channels.drdynvc.client] - Loading Dynamic Virtual Channel rdpgfx
[11:09:36:154] [51240:52086] [WARN][com.freerdp.core.rdp] - pduType PDU_TYPE_DATA not properly parsed, 562 bytes remaining unhandled. Skipping.

Good opportunity to forward this to the Flatpak team to fix. Remmina is an important app in the space and this will crop up more in the future.

I mark mine as solution then :wink: