Remote desktop access Fedora 20 via xming

Hi all,
I’m trying to get remote desktop access from windows 10 machine to Fedora server 20. Used to work perfect on my previous setup with Fedora 14.
I have putty and xming installed on my W10 and can access using putty + launch a GUI program like gedit from putty.
I tried changing X11forwarding in /etc/ssh/sshd_config but not luck.
All I get is a blank Xming window
I don’t have many much options to install new software as it’s a closed and restricted network.

Fedora 20 is very end of life. Please consider upgrading to Fedora 35 and if you continue to have problems, feel free to ask again.


Tried the same with Fedora 35 as a VM on my laptop and the same issue.
Do you have advise other than upgrade EOL which isn’t currently possible and wouldn’t solve my problem anyway?

Fedora supports upgrades up to two versions at a time. It would be far more work to incrementally upgrade Fedora 20 to Fedora 35 than to backup and do a fresh install.

Fedora 35 defaults to Wayland for Gnome, so on the login screen, you’ll want to click on the gear icon and start Gnome with Xorg if you want ssh X forwarding to work as Wayland does not support it.

As to Fedora 20, my guess is that the SSL/TLS cryptographic methods are likely now too old for Windows 10/11 to connect to it any more and there’s no easy workaround for that. Not only is it end of life, but Fedora has had a number of significant changes to its cryptographic libraries since then, meaning that any sort of backporting would be a heroic effort and likely to break a lot of stuff.

1 Like

That seems unlikely to be the reason if the connection from xming on W10 to F14 worked.

Can you confirm you can establish a ssh connection to your F20 box?

1 Like

For what it’s worth, it’s likely that neither Fedora version works against Windows 10/11 now that they, and every other major operating system, including Fedora, have increased baseline standards in recent years. There are a number of old gentoo boxes I’ve seen recently that not only Fedora, but CentOS Stream 8 won’t talk to any more. The problem is only going to get worse. There is no obvious backport here. Upgrading to a supported version is the only real path forward here.

1 Like

Yes, I can get SSH using putty. Also, I have much more older Sun Solaris systems that I can connect to remotely from W10 so it’s very unlikely that W10 is the problem

That’s not true. Gnome uses XWayland and supports running any X-based app in it when using a Wayland display.

However, you may run into issues if SSH’ing into a machine where you have already logged in with Wayland. GTK-based applications will see the Wayland connection first and prefer it over the X environment variable provided by ssh -X. You can force such apps to prefer X by setting GDK_BACKEND=x11 before running them.

1 Like

Any suggestions on how to make W10 to F20 xming work?

There isn’t much to go on at the moment, so we’re all guessing what it could be. Does xming have some place where it logs errors, maybe some file or a dialog box? We need to know why it isn’t working. We can then try to get it to work for Fedora 35, and hope that it works for F20 etc. too.