R-Linux does not start

I installed R-Linux but when I launch it nothing happens after I enter my password for elevated execusion.

Hi @marbar , welcome to the Fedora community!
If you’ve not had a chance yet, please look at the #start-here category. It has some very useful information on using the forum and tips on Fedora usage.

Can you elaborate a bit on R-Linux? What is it and how did you install it?


R-Linux is a data recovery tool (Data Recovery and File Undelete freeware for Linux files). I downloaded a rpm and installed it.

Don’t know the tool, does seem to be quite old. Is it still supported? Do they have a forum or irc?

What exactly are you trying to do?
Maybe someone here know a tool (from Fedora repo) that can do the same recovery for you…

I have had good success in recovering lost/damaged/deleted files & partitions using TestDisk and Photorec, both of which are in the Fedora repositories (both in package testdisk). If you’re uncomfortable using the command line, there is also a GUI version of photorec (package qphotorec), though I never tried that.

1 Like

I contacted their support team and made some tests without success. I’ve just provided more information to them

Thanks, I will try your proposal if I cannot get R-Linux working. I tried this tool as I’ve seen a tuto of a recovery of a Seagate Central with same issue as I have

You can test @lcts suggestions while you wait on feedback. Testdrive is not doing harm to the existing file system. It will just try to read it and place a copy of what was recoverable in a custom directory. Moreover, you know it is working since it’s in Fedora’s official repository.

Today I learned there’s a difference between R-Studio (data recovery software, by the makers of R-Linux) and RStudio (an IDE for the R programming language). Talk about confusing!