Pulseaudio problem - help

hi all,

I have an Asus laptop and I really love SB but I have a problem that I need to solve with your help.

My audio is either muted or on max 100%. There is no in between…

I found a solution for other distros and for regular Fedora Workstation but I don’t know how to do this on Silverblue.

Solution was to edit a Pulseaudio config file and add something:

sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common

How can I make this change permanent on SB? I know it’s immutable, that’s one of the reasons I’m using it but I really need to fix this.

Thank you!

You have the following (non exclusive) options:

  • Find an equivalent file in /etc (or copy the files there) and have pulseaudio / alsa-mixer load that instead.
  • File a bug in the Fedora Bugzilla or the pulseaudio one to have this fixed upstream.
  • Build an RPM with a patch to fix your issue and use rpm-ostree override replace <pkg>. You will have to update and rebuild the RPM on updates.

Also, can you give us the link to the solution?

Here is the solution:

How can I make pulseaudio load a different file located in /etc instead of /usr?