Proton (Steam) DirectX 12

I’m trying to use Proton to play some DX 2 games.
I play a lot of them on Ubuntu and Manjaro, but no DX12 game works on Fedora 34 or 35 for me.
DX11, 10 and 9 works just fine, but every game I try that requires DX12 either just crashes or tells me that my RTX 2070 doesn’t support DX12.
I’ve tried the 470 NVidia drivers and 495 drivers (both installed via the Software Store’s Third-Party repos), but DX12 never works.
Steam is not installed as a Flatpak.

How can I fix this?

What WINE version are you using? What proton version is your game using? Is Steam set for compatability ? Here are some screenshots that could help.

For game specific Proton builds (wider compatability)

WINE support (Typically WINE Staging has produced good reults for many people)

I have been using Fedora for gaming since 2016, these things have come in handy along the way.

I don’t have Wine installed.
Proton uses its own Wine version (and comes with it), so it shouldn’t even need it.
Any Proton version 6 and above kind of just kills the game, or the game complains that DX12 is missing.
Proton versions below 6 seems to work, and DX11 games and such run just fine.
So I’m guessing there are some issues with VKD3D on Fedora (at least via Steam).

A few experiments people can try out;
Run No Man’s Sky with Proton Experimental or generally anything above Proton 6 - this works fine in most distros but not Fedora 35.
Run Death Stranding with Proton Experimental - this works in most distros but gives the error “Your GPU RTX 2070 does not support DirectX 12”

I understand your point, but having at least all the build dependencies installed has helped in the past.

This is something you could post on the Proton github instead.

This to me sounds like something you could post on protondb.
There are also different Proton builds (GloriousEggroll, others) to help.
I personally have not had major issues with DX11/12 games on Fedora, but again my install is different from yours. I do also have an Nvidia system(GTX970) and an AMD system (RX5700XT).

1 Like

I gave this a try, but it sadly behaves the same.

I’m not sure if the Proton people would care, as this works in every Linux distro I’ve tried so far, except for Fedora.
So it sounds more like something Fedora should look into…

I’ve tried GE, but it behaves almost exactly like Proton Experimental, where the game just dies or complains about DX12 not being available.

I guess I’ll just have to wait for Fedora 36 and give it another try at that point.
Thanks for the help!

I have the same issue with my installation. If I was not using my machine to run my Oracle databases test environment, I would already installed another linux distro, because it seems that no one cares. As stated by other users, directx12 works fine on other linux distributions, the issue is Fedora related.
We always complained how bad linux gaming was, that no one cared about gaming on linux, and when we finally got a big company developing solutions for more games be available on linux, we bump in a wall in the linux side.

I don’t have the two games mentioned, I am playing Elden Ring w Fedora 35 and Proton experimental bleeding edge and Elden Ring is…somewhat DX12?

I haven’t experienced any issues either. I’m running the Steam Flatpak though.

Ok, I got the DX12 to work. The solution is “DO NOT USE” the rpmfusion Steam client, use the flatpak Steam app. The only problem is that I have already downloaded many games on my rpmfusion Steam, and the flatpak Steam uses another directory to store games, I will figure out how to change the directory and use the games that I have already downloaded. I tested the Hellblade game on DX12.

1 Like

You can use flatseal to give the steam flatpak access to the folder the games are in.

Then add it to the Library (Preferences → Downloads → Steam Library Folders)

Have you noticed any change to this? Is the Flatpak version of Steam the only way to get DX12 working with Steam games? If at all possible, I’d prefer to not use Flatpak versions of things I can get through the repositories. Has anyone heard any news of improvements regarding this? Perhaps Fedora 36 will help?

I had this symptom.
I resolved it by upgrading from Fedora 35 → 36, in order to get access to Mesa 22