I seems to have break my amdgpu driver related dependency

I used to install amdgpu-pro for a need of opencl, however I don’t have the need now, and it is mentioned on ProtonDB that a game don’t start with amdgpu-pro, so I used amdgpu-install (the old version when I install gpu-pro) to uninstall the drivers, and tried to install the open one from dnf. (Radeon RX 5700 XT)

However, I must have missed something, since now all games that rely on Proton cannot work complaining about missing Direct 11/12 support (or start up with 1~2 fps). Games like Dota with native vulkan still works perfectly fine.

The old version of amdgpu-install have error as

No match for argument: amdgpu-versionlist
Error: Unable to find a match: amdgpu-versionlist
Last metadata expiration check: 0:29:18 ago on Thu 02 Dec 2021 08:39:57 PM CET.
No match for argument: amdgpu-pro-versionlist
Error: Unable to find a match: amdgpu-pro-versionlist

I tried to download the newest amdgpu-install to fix it, however there seems to be a bug:

AMDGPU 21.40.1 repository                                                                                                                      193  B/s | 178  B     00:00    
Errors during downloading metadata for repository 'amdgpu':
  - Status code: 404 for https://repo.radeon.com/amdgpu/21.40.1/rhel//main/x86_64/repodata/repomd.xml (IP:
Error: Failed to download metadata for repo 'amdgpu': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
Ignoring repositories: amdgpu

The link it uses is empty (somehow there is a double slash, where should be a version number), then I try to install manually every rpm file from Index of /amdgpu/21.40.1/rhel/8.5/main/x86_64/

However, when I try to install amdgpu-dkms-1:, error comes as:

Building for 5.15.5-200.fc35.x86_64
Building initial module for 5.15.5-200.fc35.x86_64
Deprecated feature: REMAKE_INITRD
Error! Bad return status for module build on kernel: 5.15.5-200.fc35.x86_64 (x86_64)
Consult /var/lib/dkms/amdgpu/5.11.32-1337797.el8/build/make.log for more information.
warning: %post(amdgpu-dkms-1: scriptlet failed, exit status 10

Error in POSTIN scriptlet in rpm package amdgpu-dkms
  Verifying        : amdgpu-dkms-1:                                                                                                        1/1 



and when it comes to amdgpu-core, it failed to install

Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                       1/1 
  Running scriptlet: amdgpu-core-                                                                                                          1/1 
ERROR: This package can only be installed on EL8.
error: %prein(amdgpu-core-0: scriptlet failed, exit status 1

Error in PREIN scriptlet in rpm package amdgpu-core
  Verifying        : amdgpu-core-                                                                                                          1/1 

1 Like


Could you check what your currently installed amdgpu driver with:

$ dnf list installed *amdgpu*

The default amdgpu driver on Fedora I believe is xorg-x11-drv-amdgpu.

Btw, from your post we can see the *.el8.noarch naming. I believe it intended for Red Had Enterprise Linux 8.

1 Like

I don’t know why but the regrex seems don’t work, so I used grep

➜  ~ sudo dnf list installed | grep amd
amdgpu-lib.x86_64                                21.20-1271047.el8                      @amdgpu                                             
amdgpu-pro-core.noarch                           21.20-1271047.el8                      @amdgpu                                             
clinfo-amdgpu-pro.x86_64                         21.20-1271047.el8                      @amdgpu                                             
comgr-amdgpu-pro.x86_64                          2.1.0-1271047.el8                      @amdgpu                                             
hip-rocr-amdgpu-pro.x86_64                       21.20-1271047.el8                      @amdgpu                                             
hsa-runtime-rocr-amdgpu.x86_64                   1.3.0-1271047.el8                      @amdgpu                                             
hsakmt-roct-amdgpu.x86_64                        1.0.9-1271047.el8                      @amdgpu                                             
libdrm-amdgpu.x86_64                             1:2.4.100-1271047.el8                  @amdgpu                                             
libdrm-amdgpu-common.noarch                      1.0.0-1271047.el8                      @amdgpu                                             
libwayland-amdgpu-client.x86_64                  1.18.0-1271047.el8                     @amdgpu                                             
libwayland-amdgpu-egl.x86_64                     1.18.0-1271047.el8                     @amdgpu                                             
libwayland-amdgpu-server.x86_64                  1.18.0-1271047.el8                     @amdgpu                                             
llvm-amdgpu-libs.x86_64                          1:12.0-1271047.el8                     @amdgpu                                             
mesa-amdgpu-dri-drivers.x86_64                   1:21.1.0-1271047.el8                   @amdgpu                                             
mesa-amdgpu-filesystem.x86_64                    1:21.1.0-1271047.el8                   @amdgpu                                             
mesa-amdgpu-libEGL.x86_64                        1:21.1.0-1271047.el8                   @amdgpu                                             
mesa-amdgpu-libGL.x86_64                         1:21.1.0-1271047.el8                   @amdgpu                                             
mesa-amdgpu-libGLES.x86_64                       1:21.1.0-1271047.el8                   @amdgpu                                             
mesa-amdgpu-libgbm.x86_64                        1:21.1.0-1271047.el8                   @amdgpu                                             
mesa-amdgpu-libglapi.x86_64                      1:21.1.0-1271047.el8                   @amdgpu                                             
mesa-amdgpu-libxatracker.x86_64                  1:21.1.0-1271047.el8                   @amdgpu                                             
mesa-amdgpu-vdpau-drivers.x86_64                 1:21.1.0-1271047.el8                   @amdgpu                                             
ocl-icd-amdgpu-pro.x86_64                        21.20-1271047.el8                      @amdgpu                                             
opencl-rocr-amdgpu-pro.x86_64                    21.20-1271047.el8                      @amdgpu                                             
teamd.x86_64                                     1.31-4.fc35                            @fedora                                             
texlive-examdesign.noarch                        9:svn15878.1.02-45.fc35                @fedora                                             
xorg-x11-amdgpu-drv-amdgpu.x86_64                1:24.1.0-1271047.el8                   @amdgpu                                             
xorg-x11-drv-amdgpu.x86_64                       21.0.0-1.fc35                          @fedora                                             
➜  ~ sudo dnf list installed *amdgpu*  
zsh: no matches found: *amdgpu*

Yeah but it seems amd only pack for rehl and name all rpm this way. I actually downloaded the version for centOS.

I got the xorg-x11-drv-amdgpu, the main part of the gpu seems fine, since native Vulkan games like Dota is running perfectly fine (even better before I uninstall amdgpu-pro)

The problem is, all the games that rely on Proton (steam’s version of wine), is not working and complaining about direct x dependency, but I can’t find what I missed and what had happened to amd’s driver manage program.

I’m sorry I was miss read. I though your amdgpu not working at all. I never really into game.

I remember there an article about gaming on Fedoramagazine here which I believe it’s a respons to LTT YouTube channel about Gaming on Linux Challenges. Also there a documentation on Fedora Docs about proton with Steam here.

If everything mentioned on those two articles already installed on your system and configured as the articles suggested, may be you could try to run sudo dnf distro-sync to find if there any missing packages and install it.

1 Like

BTW, the reason why dnf list installed *amdgpu* wouldn’t list any results for you is probably that there was a file in the current directory that matched the *amdgpu* pattern and that’s what was passed on to the dnf command. If you do dnf list installed \*amdgpu\* or dnf list installed '*amdgpu*', it should work.

1 Like