Proprietary NVIDIA Driver Fails to Update - F35

Using the F35 branch of Silverblue here and I am getting the following.

error: Running %post for akmod-nvidia: bwrap(/bin/sh): Child process killed by signal 1; run `journalctl -t 'rpm-ostree(akmod-nvidia.post)'` for more information
Oct 28 09:00:08  rpm-ostree(akmod-nvidia.post)[15140]: RPM build errors:
Oct 28 09:00:08  rpm-ostree(akmod-nvidia.post)[15140]:     Unable to open sqlite database /usr/share/rpm/rpmdb.sqlite: unable to open database file
Oct 28 09:00:08  rpm-ostree(akmod-nvidia.post)[15140]:     cannot open Packages index using sqlite - Operation not permitted (1)
Oct 28 09:00:08 rpm-ostree(akmod-nvidia.post)[15140]:     cannot open Packages database in /usr/share/rpm
Oct 28 09:00:08  rpm-ostree(akmod-nvidia.post)[15140]:     user mockbuild does not exist - using root
Oct 28 09:00:08  rpm-ostree(akmod-nvidia.post)[15140]:     group mock does not exist - using root
Oct 28 09:00:08  rpm-ostree(akmod-nvidia.post)[15140]:     user mockbuild does not exist - using root
Oct 28 09:00:08  rpm-ostree(akmod-nvidia.post)[15140]:     group mock does not exist - using root
Oct 28 09:00:08  rpm-ostree(akmod-nvidia.post)[15140]:     Unable to open sqlite database /usr/share/rpm/rpmdb.sqlite: unable to open database file
Oct 28 09:00:08 rpm-ostree(akmod-nvidia.post)[15140]:     cannot open Packages index using sqlite - Operation not permitted (1)
Oct 28 09:00:08  rpm-ostree(akmod-nvidia.post)[15140]:     cannot open Packages database in /usr/share/rpm
Oct 28 09:00:08  rpm-ostree(akmod-nvidia.post)[15140]:     Bad exit status from /var/tmp/rpm-tmp.KlD6YJ (%prep)

Any thoughts here?

Probably have to wait for the akmod drivers to be updated to F35SB perhaps. They are normally just behind, and F35SB is still beta.

1 Like

i had the same problem and i had to temporarily remove the nvidia drivers.

regards,