Rpm-ostree update failed - akmod

Hi there…

Got the following error while running post scripts this morning…
Running post scripts… done
error: Running %post for akmod-nvidia: bwrap(/bin/sh): Child process killed by signal 1; run journalctl -t 'rpm-ostree(akmod-nvidia.post)' for more information

currently using - Deployments:
● fedora:fedora/35/x86_64/silverblue

this isn’t a new issue as I’ve seen some

the solution provided there

wget https://kojipkgs.fedoraproject.org//packages/rpm-ostree/2021.1/4.fc33/x86_64/rpm-ostree-2021.1-4.fc33.x86_64.rpm
wget https://kojipkgs.fedoraproject.org//packages/rpm-ostree/2021.1/4.fc33/x86_64/rpm-ostree-libs-2021.1-4.fc33.x86_64.rpm
sudo rpm-ostree usroverlay
sudo rpm -Uvh ./rpm-ostree-2021.1-4.fc33.x86_64.rpm ./rpm-ostree-libs-2021.1-4.fc33.x86_64.rpm
sudo systemctl restart rpm-ostreed.service
rpm-ostree upgrade
systemctl reboot

I’m kinda new to silverblue… will the solution work? what is the right rpm for my current deployment? thanks.

I ran into the same issue but on a fresh silverblue 34 install, while installing the nvidia drivers yesterday evening. I’m not at my desktop currently, so I can’t provide the exact logs, but in my case I think the underlying issue is different from the issues you mentioned. Something with an sqlite file which couldn’t be read (if I remember correctly). Don’t forget to use the mentioned journalctl command to get a hint towards the underlying issue.

in bugzilla I found some bugs for rpm-ostree. Could be the answer. You could join the bug to follow its progress.

This has put me on the right track, I managed to fix my issue by increasing the open file descriptor limit. My cpu (Ryzen 9 3900XT has too many threads for the default value apparently).
I have increased it by uncommenting DefaultLimitNOFILEin both /etc/systemd/user.conf and /etc/systemd/system.conf and setting it to 65535 and running sudo systemctl daemon-reexec. Logging out and in didn’t work for me so I rebooted, the last command was probably unnecessary because of that. After rebooting I could install the Nvidia driver. If anyone else wants to look for the buglist of rpm-ostree, this is the url with the query I used: https://bugzilla.redhat.com/buglist.cgi?quicksearch=rpm-ostree

i tried updating again this morning… i think the issue addressed. thanks all for your reply.

@snooranges6925 since your problem was solved, please mark the thread as solved (by marking one of the posts, in this case your own last post), it can help others with similar problems to find answer quicker.