Cannot update silverblue

Hello everyone i have silverblue 33 and since a couple of days I cannot upgrade because after post script I have this error
error: Running %post for akmod-nvidia: Executing bwrap(/bin/sh): Child process killed by signal 1; run 'journalctl -t 'rpm-ostree(akmod-nvidia.post)' for more information

and in journal I have
/usr/bin/kmodtool required by nvidia-kmod-3:460.39-1.fc33.x86_64 gcc required by nvidia-kmod-3:460.39-1.fc33.x86_64 xorg-x11-drv-nvidia-kmodsrc >= 3:460.39-1 required by nvidia-kmod-3:460.39-1.fc33.x8
Does anyone had this problem too and have a solution?
thanks

I don’t remember the exact error but I’m pretty sure I had something like this today while trying to update. I definitely remember something bwrap and somthing nvidia. What I did is I tried to update rpm-ostree and rpm-ostree-libs manually in rpm-ostree usroverlay because I knew these packages had an update to fix issues with libsolv. And the update succeeded.

I’m not sure this will solve your problem, but in case it is related to the rpm-ostree/libsolv issue: this is solved in rpm-ostree-2021.1-4.fc33 and bugzilla bug 1925717 contains details on the rollback procedure if necessary for a succesful upgrade.

1 Like

I hit this too, just removed any nvidia-related layered packages, then removed any related kernel args with rpm-ostree kargs --editor (that would be: rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1).

Upon restarting you should be able to update, reinstall the nvidia packages and add back the kernel args. You may not necessarily need to remove your kernel args and reboot for this to work, but I did it all the same.

Thanks to everyone. I manged to solved with a mix of the proposed methods. I tried to remove nvidia driver but I’ve got some error from ostree, so I tried downgrade libsolv like suggested but also couldn’t upgrade for same nvidia error. So finally I removed ndivia after I’ve downgraded libsolv and then I reinstalled nvidia driver. Now everything works

1 Like