Problems with BforArtists flatpak app


I upgraded to Fedora 40 recently, while most of it has been great I’ve had several major issues. One of which is BforArtists app on flatpak (its a fork of Blender).

It was working fine on Fedora 39, both on X11 and Wayland. But it has started to give me the error below since I upgraded. Please note that the tar.gz version works, but it has a few issues like inverted scroll (which I can’t for the life of me figure out the cause for, its just that app and nothing else and settings arent set for inverted scroll).

I very much depend on this software to run for my work so I would appreciate any help. I have tried my best to find solutions everywhere I could before making a post here.

flatpak run --branch=stable --arch=x86_64 --command=bforartists --file-forwarding de.bforartists.Bforartists @@ %f @@

Can’t find font: /home/ams/Documents/Work 2/Big Work/Resources/Fonts/Montserrat/static/Montserrat-Regular.ttf
EGL Error (0x3000): EGL_SUCCESS: The last function succeeded without error.
EGL Error (0x3000): EGL_SUCCESS: The last function succeeded without error.
EGL Error (0x3000): EGL_SUCCESS: The last function succeeded without error.
EGL Error (0x3000): EGL_SUCCESS: The last function succeeded without error.
Warning: No OpenGL vendor detected.
bforartists: …/external_epoxy/src/dispatch_common.c:872: epoxy_get_proc_address: Assertion `0 && “Couldn’t find current GLX or EGL context.\n”’ failed.

Regarding my setup:

  • KDE 6.0.4 Wayland Fedora 40.
  • Kernel 6.8.7-300.fc40.x86_64 (64 bit)
  • GPU: Nvidia GeForce RTX 3060
  • CPU: AMD Ryzen 5 5600 6-Core

dnf list installed '*nvidia*'

akmod-nvidia.x86_64                                  3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.8.5-201.fc39.x86_64.x86_64             3:550.67-1.fc39              @@commandline                   
kmod-nvidia-6.8.6-200.fc39.x86_64.x86_64             3:550.67-1.fc39              @@commandline                   
kmod-nvidia-6.8.7-200.fc39.x86_64.x86_64             3:550.76-1.fc39              @@commandline                   
kmod-nvidia-6.8.7-300.fc40.x86_64.x86_64             3:550.76-1.fc40              @@commandline                   
libva-nvidia-driver.x86_64                           0.0.11-3.fc40                @fedora                         
nvidia-gpu-firmware.noarch                           20240410-1.fc40              @updates                        
nvidia-modprobe.x86_64                               3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver
nvidia-persistenced.x86_64                           3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                               3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                           3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64                      3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.i686                   3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64                 3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64                   3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.i686                        3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                      3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64                     3:550.76-1.fc40              @rpmfusion-nonfree-nvidia-driver

Things I have tried:

  • Reinstalled the Nvidia drivers and components from here: Howto/NVIDIA - RPM Fusion (Note I just changed ‘install’ to ‘reinstall’, and ran the commands)
  • Looking for similar issues, I found almost exact same issue here but there is no solution: #107957 - Crash in epoxy_get_proc_address "Could'nt find current GLX or EGL context." - blender - Blender Projects
  • I have ran sudo dnf update sudo dnf upgrade sudo flatpak repair flatpak uninstall --unused sudo ldconfig
  • I have set export QT_QPA_PLATFORM="wayland;xcb" and export QT_QPA_PLATFORM="xcb". Both via cli and in ~/.bash_profile (and rebooted) without any change.
  • I have run the flatpak run command for BforArtists with just the app name and nothing else. Same error.

Please note that nothing I have tried has changed the error message nor made it launch.

I would be fine with running just the tar.gz version if not for inverted scroll. I haven’t tried debugging that at all since I rather have the flatpak version work if possible. Or I might have to downgrade to Fedora 39.

Hopefully I have provided all info, but let me know if something else is needed.