New Fedora installation freezes on font install

Hi, I just installed Fedora for the first time, and can’t install a font - when I click ‘Install’ in the font manager app, it says ‘Installing’ but the process is never finalised, and if I click close, or even try to move the window, the system freezes. Is this a known issue? I did a search both in the forums and on the wider web, but could not find anything relevant. I there an alternate font manager app that I can try to see if it that’s where the issue is originating?

Update: I circumvented this by installing fonts using command line, but this remains a potential concern for apps freezing the system.

Another freeze just happened when closing the Settings window, so this must be a general issue, not specific to the fonts manager.

I ran the uname command to check kernel, turns out I’m running 5.18.11-200.fc36.x86_64, which I think is the latest one?

Update: installed an Nvidia driver, will check if this has solved the issue and report back.

You may also have an issue with the video driver or graphical environment.

  1. Do you have an nvidia GPU?
    a. If yes are you using the nouveau driver or the nvidia driver?
  2. Are you using wayland or xorg?
    a. Does the same problem occur if you switch from wayland to xorg or vice versa?
  3. What is your desktop? Gnome, kde, or other?

Thank you for the reply.

  1. Yes. I am not sure which of those two I was running before I installed the Nvidia driver I mentooned above, but if I run nvidia-settings now, it shows 515.57 Nvidia driver being used
  2. Using Wayland. I have never switched between these, so would need to research how to do that and verify
  3. Gnome desktop

In the ~three hours since I installed the Nvidia driver, I have not had the freeze issue. I also installed Fedora on my laptop, so now have two platforms to monitor this on.

Simple switch using the gear icon at the lower left of the password entry screen. If the install of the nvidia driver solved it then it seems possible the nouveau driver for the nvidia card was the culprit.

Please report back and mark the solution if solved.

No freezes detected on my laptop, and no freezes happening on the desktop since GPU driver installation. Marking the relevant post as the solution for those who may look this thread up in the future.

Well, looks like I spoke too soon. I installed Login Manager Settings via flatpak from here Flathub—An app store and build service for Linux , and once I make changes and click Apply, the system freezes and the only thing I can do is a hard reset. The same thing happens on my laptop (same latest Fedora version).

One of the problems that may occur with flatpak vs rpm installs is that the rpm install for fedora is tested to work with the current software packages.

Flatpaks, OTOH, are inherently configured to work with software as it was at the time, and as installed and configured by the developer. This may not (and likely won’t) match the user’s system.

When using a flatpak to do parts of system admin it seems possible that the flatpak is not as up-to-date as the system and it may make changes to the system that are not compatible with the current state of the system.

For systems that do not change much, such as the LTS releases, it would not likely be an issue. However, for those that change rapidly such as fedora, it may become an issue quickly.

Most apps are not doing system admin so they usually do not see the same problems.

Thank you for that information. The interesting part is that seemingly the changes I am applying do actually get carried through - once I reset the system, I can see the successful application on the next bootup.