Black windows in X11 Nvidia Fedora35


After yesterday’s system update, I’ve rebooted the system and some windows become black (like skype, slack, vlc etc). The window looks like a black square.

My system info:
OS: Fedora 35
Kernel: 5.16.16-200.fc35.x86_64
GPU: NVIDIA GeForce GTX 1060

I’ve tried to reinstall Nvidia driver.

In Wayland all work well.

Any ideas?

These are all flatpak apps, right? I’ve seen this on my previous F35 setup (I even filed a bug), but for some reason it is working now for me (GTX 1650) even on X11 with the latest Nvidia driver…

If you run them on the command line does the output show any error?

I’ve tried to update Nvidia drivers from and it didn’t help :frowning:

As well I’ve tried running slack from the console and I have the following errors:

[4827:0324/] EGL Driver message (Critical) eglInitialize: Invalid visual ID requested.
[4827:0324/] eglInitialize OpenGLES failed with error EGL_NOT_INITIALIZED

Mmmh… those EGL initialization errors seem suspicious, I’d try to take a deeper look into it. I did a quick search and found a couple of resources, maybe they are helpful. Some common problems that seem to be related is the use of Nvidia Prime, don’t know if that’s your case (I’d guess not since you are not on a notebook)

BTW I also ran Sporify from the terminal and these errors don’t appear here.

If you want you can post here your Xorg.conf, maybe there’s a clue there.

1 Like

Thank you!

Now all works well in X11.

I’ve done what is described here Howto/Optimus - RPM Fusion

And after reboot all works!

1 Like

Nice! :smile: Just for the record, what exactly did you change in order to fix the problem?

My steps:

And success :slight_smile:

1 Like

Which part? The power-management opt-in stuff, or setting __NV_PRIME_RENDER_OFFLOAD=1 and/or other environment variables?

Ugh, and this topic is tagged #wayland — I assume that’s an auto-tag, and stems from the brief mention in the OP that this isn’t a problem under Wayland.

…Whatever’s doing the auto-tagging here should probably cut it out, because it clearly isn’t very good at distinguishing mentions of actual topics from non-topic keywords that just happen to appear in posts.

Seems I can’t edit it.

Remove it if you can, please.

No more able than you, I’m afraid. I’ve settled for officially complaining about the auto-tagger.

I removed it … but if you scroll up you should be able to edit the title as OP.
Is there not a pen beside the the Title?

Hi @lensky84 , I second what @ferdnyc asked, please be more specific about what you’ve done. This way you can hopefully be more helpful for others that end up here with the same problem you had :wink:

1 Like

Hi @ocosta and @ferdnyc

I can’t edit the comment that you’ve mentioned :frowning:
And the title of the post or post content.

I’ve edited the title of the link in another comment.

You registered yesterday. The system still makes you restrictions because you are new. After a week or so you should be able to go thru all this again and make the necessary changes. This is a security feature from the Software here to avoid spammers.

See here (you are still trust level 0):

No need to edit a past comment, just add another one at the end of this thread detailing what you have done – and perhaps mark this new one as the solution. This will provide an immediate jumping point for anyone seeking a solution.