Black screen after installing negativo17 nvidia drivers on optimus laptop


I have a fresh installation of Fedora MATE 30 on an optimus laptop:

$ lspci |grep -E "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)

I am trying to install nvidia drivers from the negativo17 repository. I also used some instructions provided here.

The steps I 've taken are:

$ sudo dnf config-manager --add-repo=
$ sudo dnf upgrade
$ sudo dnf install kernel-headers kernel-devel
$ sudo dnf install nvidia-driver nvidia-driver-libs nvidia-libXNVCtrl nvidia-driver-cuda nvidia-driver-cuda-libs nvidia-driver-NVML nvidia-persistenced nvidia-modprobe nvidia-settings nvidia-xconfig dkms-nvidia
$ sudo dkms autoinstall

If I understood the instructions on the negativo page the commands below are not needed. I tried them when the ones above didn’t work.

$ sudo echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf
# Above didn't work due to permissions, was done manually!
# Edit /etc/sysconfig/grub to append `rd.driver.blacklist=nouveau` - already done by negativo post install scripts?
$ sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

The problem is that when I try to load the latest kernel available, 5.1.6, I am greeted with a black screen instead of a login screen. I have also kernel 5.0.9 installed, which works with the nouveau driver, because I was running 5.1.6 when I tried to install the drivers.

The nvidia drivers appear to be installed:

$ ls -la /boot | grep initramfs-5
-rw-------.  1 root root 26110997 Jun  8 02:50 initramfs-5.0.9-301.fc30.x86_64.img
-rw-------.  1 root root 23908630 Jun  8 10:58 initramfs-5.1.6-300.fc30.x86_64.img
$ dkms status
nvidia, 430.14, 5.1.6-300.fc30.x86_64, x86_64: installed

but on the other hand the nvidia settings application doesn’t show up when I boot in 5.0.6 even though the package is installed.

When I boot in the 5.1.6 image and get a black (as if powered off) screen instead of a log in screen, the system seems to be working. While reading information from this bug report on negativo17 github repo I once tried entering my password and I think I managed to log in. In any case after selecting the 5.1.6 image the only thing I can do to get my screen to work is to press Ctrl + Alt + F2 and use this console to do something. But I have to reboot into the 5.0.9 image if I am to use the Desktop environment.

Any ideas on what might be wrong and I can’t get the proprietary nvidia drivers to work? I thought maybe nvidia drivers didn’t support 5.1 in Fedora but I didn’t find any reference about it. And the bug report I mentioned says that some users in F29 got a black screen when they should be shown a log in screen. I think I am getting the same but I can’t be sure?

I don’t know about optimus but i have the 1050 and and used the negativo repo for awhile.I would suggest remove the blacklist nouveau in the /etc/modprobe.d/blacklist.conf. that way if the driver doesn’t load you can still log in the desktop.I installed dnf install nvidia-driver nvidia-libs.i686 dkms-nvidia nvidia-settings.With the latest 5.1 kernel i did have to reboot twice to get the dkms to build the driver.The negativo site has some pretty good info on how to work with optimus as well.Also when you log in make sure to check the gnome on xorg and don’t use wayland.

By default the negativo install doesn’t add the /etc/modprobe.d/blacklist.conf entry. The problem is still there. Also since I am using Fedora MATE wayland shouldn’t be a problem since the MATE DE is still only X11.

I don’t know if it would be worth removing them blacklist nouveau command line option from the 5.1.6 image on the grub menu, given your suggestions.

The good thing is that my home directory is separate then my root directory and re-installs are faster :biohazard:

I just tried the rmpfusion nonfree repo instructions:

$ sudo dnf install xorg-x11-drv-nvidia akmod-nvidia

I got the blackscreen instead of login there as well. I could get a shell by trying Ctrl+Alt+F2 and the blackscreen by typing Ctrl+Alt+F1 and alternate between them. The fortunate thing with the rpm fusion repo is that it uninstalls cleanly. Somehow the negativo17 repository always leaves my system unable to boot after uninstallation :frowning:

I don’t know if the problem is with the drivers or the DE(MATE or lightdm) or how to investigate for it.

I’m using Mate and rpmfusion on and older computer and haven’t had any problems.You might try and remove the blacklist nouveau command and see if you can log in then try again and see what happens.Make sure if your using rpmfusion you disable the negativo repo as they are not compatible.Sorry i can’t help more.

I’m using the drivers from negativo17 and Fedora 30 MATE on kernel 5.1.6. I don’t have issues. But I’m not running on an optimus laptop.

So it wasn’t just me! I was confused by this because after the first reboot, the nvidia driver was not loaded, but dkms status showed the module was built without error. Rebooting a second time loaded the driver without problems. This never happened before.

I ended up trying pure Fedora, as nothing I 've tried with Fedora MATE worked. The rpmfusion nvidia drivers worked without problems. Even x11 was set up by default, for both the session and gbm, without me needing to do anything. I 'd prefer to find out how to work things out on MATE but I couldn’t.

Gnome wasn’t as usable as I 'd like, so I am back to Fedora MATE 30. I 'm using the nouveau drivers for now until I find a solution for how to install nvidia drivers successfully on my laptop.

As a side note another Fedora MATE user shared his notes on how he successfully installed nvidia drivers on his optimus laptop on here. I haven’t tested them myself yet.