F35 + NVIDIA + Wayland - Problems

With the currently released version of Fedora 35 and the NVIDIA 495.44 driver when using Wayland I have several problems:

  1. Geary crashes with the following error message:
    geary: …/src/wayland-thread.c:87: wlExternalApiLock: Assertion `!“failed to lock pthread mutex”’ failed.

  2. Evolution crashes with the following error message:
    evolution: …/src/wayland-thread.c:87: wlExternalApiLock: Assertion `!“failed to lock pthread mutex”’ failed.

  3. The Zoom and Skype clients launch but their window is transparent with no elements inside.

  4. Shotwell freezes the whole desktop and I have to login from a terminal and kill the session in order to recover.

1 Like

From what I know, the Nvidia drivers are not Wayland friendly. Are you on Gnome? GDM disables wayland by default if the proprietary Nvidia drivers are installed:


Zoom has not been updated to work with the new Wayland either. Here’s a discussion on that:


The errors don’t quite tell us if this is related to Nvidia, but a quick test would be to check with X11 to see how it goes?

1 Like

In addition, I’ve noticed that firefox crashes if WebRender is enabled (F35 + Nvidia + Wayland).

How to reproduce:

  • about:config
  • gfx.webrender.enabled = true
  • restart firefox → crash on startup
  • undo by starting firefox in safe mode (firefox --safe-mode)

Firefox bug report: 1739599 - Crash on start-up with WebRender on Wayland (Fedora 35, Nvidia proprietary drivers, Gnome 41)

1 Like

I believe that the problem with Geary and Evolution is related to this issue:



Gnome Web (Epiphany) also crashes, in addition to above already reported.
On XPS17 with F35, nvidia, gnome on wayland.
Workaround: X11 session works fine if you can live without the new gestures.

Because it was mentioned by Ankur. Wayland on nvidia should work. There have been articles recently about the work done to improve the support. Nonetheless Wayland session worked already on F34 with nvidia driver (470?).



I believe the assertion “failed to lock pthread mutex” could be that issue upstream in egl-wayland:



How about totem, gnome-maps?

Same problem.

totem: Gdk-Message: 13:10:54.023: Error flushing display: Protocol error

gnome-maps: Gdk-Message: 13:11:20.753: Error flushing display: Protocol error

Our problem has also been discussed here: https://discussion.fedoraproject.org/t/fedora-34-35-upgrade-crashing-gnome-apps/70600/16

Ya. I asked that. I submitted an issue at Mutter’s git page. Hopefully someone look into it. Do you have Optimus Graphics or Just Nvidia GPU?

Also there is a bug report on Nvidia’s github.

1 Like

I also have Optimus.

1 Like

The workaround described there works for me, too: sudo dnf downgrade egl-wayland-1.1.7-2.fc35 --allowerasing


Nice. I just blacklisted Nvidia for now. Probably will switch to Bumblebee since that doesn’t require Nvidia driver’s mercy. For those who want to fix it and use Nvidia downgrade it as @thomasroder did. Downgrade egl-wayland. If anyone knows how to mark it as solution, it would help others.

1 Like

The issue has been fixed. This is how to install the patched version of egl-wayland (1.1.9-3) on Fedora 35:

sudo dnf update --enablerepo=updates-testing egl-wayland


That fixed it.