How should I report a system-wide gnome/wayland/nvidia/F36 bug?

I’m running F36 (fully up-to-date) and Gnome 42.

I cannot run any Gnome app under Wayland. Settings, fonts, mediawriter, calculator, software, etc. produce a garbled/scrambled/incoherent window, like this:


The same happened with Google Chrome until I fixed chrome://flags to set WebRTC PipeWire support to Enabled and Preferred Ozone platform to Auto.

So my system is only usable under X11, which then makes some applications – e.g., Calibre – unusable (since it relies on qt6).

As far as I can tell, my system is completely up-to-date and correctly installed (and works perfectly well under X11, albeit with the caveat above), so I assume there’s a bug somewhere.

But I cannot figure out where this bug should be reported – or, if it’s expected behavior for my particular system, how to fix it.

It’s not a bug wayland and nvidia still do not work well together.The latest nvidia drivers which are 5.15 for the latest nvidia cards are supposed to work better with wayland but older nvidia cards still have issues.If gnome is working with xorg I’d suggest just sticking with xorg. You can send the issue to nvidia or wayland and maybe someday they will deside to get the issue’s worked out.

Well, that’s depressing.

My Nvidia cards are GeForce 1080 Tis; they’re only ~4 years old. That should be recent enough, no?

At any rate, the problems I have are only with native Gnome apps, now that Chrome has been patched. I’m still hoping that there’s some setting in Gnome I’m ignorant of that will fix the problem …

Yes after all the years wayland has been out it’s kinda depressing.I have Geforce 1050 and GeForce 1650 and they work great with xorg but I haven’t tried with wayland as it seems easier to just run with xorg.

The latest nvidia drivers are 515.76-1.fc36 which was just updated in the last week.

When you say fully updated, how recently?
F36 now has kernel 5.19.12 as well as the nvidia drivers noted above.

When you have an issue such as you describe, the first thing you should try would be to run sudo dnf --refresh distro-sync to ensure that everything is fully up to date.

You should also consider if you might have packages installed from some 3rd party repo that might interfere with normal operation.

An update that failed to properly complete can cause similar failures to operate properly with packages out of sync or incompletely installed.

Please try the recovery this way before filing a bug.