Fedora 35 crashing a lot with Wayland

For probably about 3+ months Fedora has served me well, until lately everything is running like crap and a lot of programs are crashing. Some apps windows are showing black unless I disable GPU acceleration, Steam is running like crap and its hard to launch games, but if I do manage to launch a game the game runs smooth and doesn’t crash.

Launching an X11 session doesn’t have any problems and things run fine.

But with Wayland, Firefox tabs are crashing constantly. Everything is just crashing all the time and system is slowly falling apart. I was using Kernel 15.13 and thought that might be the problem so I booted up with a kernel from 2 versions ago and it’s still the same with Wayland.

How can I triage these issues and get the system running right again?

AMD FX-6300

Hi @fultonm Good morning. I should ask you to look into logs etc. And ask you to remember what new was added to your system 3+ months ago. But I trust you did these.
So I just show this link F35+NVIDIA -- How to enable Wayland?

1 Like

I would make 1 suggestion that while inconvenient might work to eleviate the stress. This suggestion is based on the fact that wayland and nvidia are still not 100% compatible, even though miles beyond what has been the case before fedora 35 and the nvidia 495 drivers.

You might pay attention to which apps are having problems when running in wayland, then use X when planning to use those apps. Steam, firefox, and others are known to still have problems with wayland and nvidia.

Alternatively you might just bite the bullet and switch to X full time, with the understanding that there is still more improvement on the way with both wayland and nvidia so performance will improve in the future even more.

Also, kernel 5.13 was pre-fedora35 so it will not work nearly as well with wayland/nvidia as the 5.15 kernel in use now. I am not even sure how well the 495 nvidia driver will work with kernel 5.13 since even today with wayland as good as it is, the nvidia 495 driver has only been ported to the 5.15 kernel and fedora 35. It is not available through rpmfusion for fedora 34.