Problem with automount internal SSD?

Hi,

I’m new to Linux and Fedora (running Nobora KDE X11), and I’m having issue with my folder configuration.

In my system, I have another SSD which contains all my music and everytime I drag and drop the music folder in “places” in Dolphin I can access the content of the folder.
However after restarting the computer, I can’t access the folder anymore and receive this message:
“The file or folder /run/media/user/nvme1n1p2/Music does not exist.”

What’s weird is that the SSD itself automounts at every login and I can access it from the “Devices” section in Dolphin.

It is a bit anoying as I can’t save my music library in Elisa or any other audio player.

I’ve also tried to change the default “Music” folder location in System settings/Session/Locations, but same thing, after restarting the option reset itselt.

Any idea what could be wrong?
Thanks!

@w-bruce-w First off Welcome to Fedora :fedora: :handshake:t5:

You mentioned Nobara, and while Nobara is a fork of Fedora, it is not supported here. I believe GE has a Discord where members of Nobara congregate. I do not have a link to their Discord ( just checked, they are invite only now. . . ).

With that being said your issue is simple and general enough,

The Directory you are trying to access does in fact not exist. This is a mount point for the drive, so when you reboot your computer you need to remount the drive.
You can set it up via the /etc/fstab file so that when you start the computer you can auto mount the NVMe.

In closing, I do not know if there are other places where Nobara users troubleshoot issues, as GE himself has said "It’s a Distro for him and Family, If you ask nicely you might get help. . . " .

Nobara is meant for experienced users who also Game.

Added mount, nobara and removed audio

Thanks @hamrheadcorvette !
Yes I’m already on the discord but the channel is flooded with Nobara specific issues, so I’d figure that my generic problem should be more visible on an official Fedora forum.

But regarding your answer, I went in the fstab file and found my SSD with the following line:
/dev/disk/by-uuid/D81E8DV21E8F88E8 /mnt/D81E8DV21E8F88E8 auto nosuid,nodev,nofail,x-gvfs-show 0 0

So, I’m assuming that auto mount is already enabled no?

1 Like

Is the by-uuid/D81E8DV21E8F88E8 the UUID of the NVMe drive you are mounting? Also, this mount point /mnt/D81E8DV21E8F88E8 is not where the drive is currently mounted at when you are using it /run/media/user/nvme1n1p2/Music

Yes it’s the same UUID. What should I change/add to the file then?

If I understand that correctly the drive should auto mount on /run/media instead right?

That’s correct. So you would need to change that path with the right UUID and the /Music directory. Then do systemctl daemon-reload to ge the config loaded.

Perfect, it’s all good now! Thanks a lot for your help!

1 Like

:tux: :fedora: