Problem after upgrade to f37 rc-1.7

I have a problem after upgrading to F37, The fedora logo appears and then it becomes a black screen and I can’t do anything and I force power-off by pressing button, I entered the emergency mode manually and run startx and this message appeared.


Try to get the Grub menu up at boot and select your previous one. Then redo the upgrade. You can also try the rescue and installed system option of the installer.

1 Like

in grub menu when entering the mode of the rescue the screen appears and always repeated.

1 Like

What laptop/hardware are you running?
Do you have nvidia graphics?


no intel

1 Like

We cannot assist if we have no info.
We need at least the type of system, make & model helps, and if possible all the details about what you did during the upgrade. Without at least some info we cannot guess as to how it may be resolved.

I have executed “dnf system-upgrade download -releasever=37”.
I have an intel integrated graphics card
What do you mean by information and how can I get it for you?


Can you check and see how much diskspace you have available?

1 Like

Hi @majora , welcome to the community.

The image shows multiple system daemon start up failures. I think the first thing to check is: did the upgrade complete correctly? If it did not, that’ll result in an inconsistent system. How did you upgrade too—was this using gnome software, or using dnf system-upgrade, or another method? Did you notice any errors/warnings during the upgrade?

At this point, I’d also backup any important files you may have on the system, just in case. You can do that using any live media (workstation/kde/any spin) to access the computer disk.

Was your network working when you dropped to the emergency mode? If it was, could you perhaps run fpaste --sysinfo and share the link here? (I can then copy it in to your post manually).

Please, this is not useful/helpful. Let’s ask folks for the required information in a friendly way—we need to remain excellent to each other. People are not expected to know what info may be relevant. It’s why we are here. :slight_smile:

1 Like

This is the type of info I asked for. Thank you for this!

I have further questions about the upgrade.

  1. Did you do dnf upgrade --refresh before doing the download?
    If you did, was it able to complete without errors?
  2. It would follow from your answer above that you likely used dnf system-upgrade reboot to actually perform the upgrade. Did that compete with no indicated errors? ( The failure to boot is an error but I am asking about something that may have been displayed in the on-screen text before the start of the boot.)

Your initial post was about errors with trying to startx from the emergency shell as root.
That would not have worked for 2 reasons. First the emergency shell does not have the graphics display manager loaded, and secondly root is never intended to start a graphical desktop.

What is required is to find out what caused the boot problem then boot normally so you can access the graphical display.

Can you boot to an older kernel from the grub menu?
If so then we can attempt to make repairs. If not then we can do the repairs by booting to a live media and work from there.

1 Like

First of all, thank you for listening to me.

  1. Yes, but I did not reboot and then executed the upgrade command.
    2.I don’t think I got an error.
    I booted by adding “” and logged into tty1.
    You have run the program “journalctl -b -1 -r”.
    How can i upload file log to you.

If there was an update to the kernel when you ran dnf upgrade --refresh then you really should have rebooted before continuing. That is done now so we will move on.

The journalctl log can be uploaded by simply pasting the text into your post and the formatting can be retained by highlighting the text with the mouse then clicking on the </> Preformatted text button on the toolbar just above the text entry screen.

When booted into the text mode, log in as your regular user instead of root. Then run uname -a and cat /etc/system-release and post the output of both here as well.

=== fpaste System Information ===
* OS Release (cat /etc/*-release | uniq):
     Fedora release 37 (Thirty Seven)
     NAME="Fedora Linux"
     VERSION="37 (Workstation Edition)"
     PRETTY_NAME="Fedora Linux 37 (Workstation Edition)"
     VARIANT="Workstation Edition"
     Fedora release 37 (Thirty Seven)
* Kernel (uname -r ; cat /proc/cmdline):
     BOOT_IMAGE=(hd0,msdos7)/vmlinuz-6.0.7-301.fc37.x86_64 root=/dev/mapper/fedora_localhost--live-root ro resume=/dev/mapper/fedora_localhost--live-swap
* Desktop(s) Running (ps -eo comm= | grep -E '(gnome-session|startkde|startactive|xfce.?-session|fluxbox|blackbox|hackedbox|ratpoison|enlightenment|icewm-session|od-session|wmaker|wmx|openbox-lxde|openbox-gnome-session|openbox-kde-session|mwm|e16|fvwm|xmonad|sugar-session|mate-session|lxqt-session|cinnamon|lxdm-session)' ):
* Desktop(s) Installed (ls -m /usr/share/xsessions/ | sed 's/\.desktop//g' ):
     gnome-classic, gnome-classic-xorg, gnome,
* SELinux Status (sestatus):
     SELinux status:                 enabled
     SELinuxfs mount:                /sys/fs/selinux
     SELinux root directory:         /etc/selinux
     Loaded policy name:             targeted
     Current mode:                   enforcing
     Mode from config file:          enforcing
     Policy MLS status:              enabled
     Policy deny_unknown status:     allowed
     Memory protection checking:     actual (secure)
     Max kernel policy version:      33
* SELinux Errors (selinuxenabled && journalctl --since yesterday |grep avc: | grep -Eo comm="[^ ]+" | sort |uniq -c |sort -rn):
           6 comm="libvirt_leasesh"
* CPU Model (grep 'model name' /proc/cpuinfo | awk -F: '{print $2}' | uniq -c |
     sed -re 's/^ +//' ):
     4  Intel(R) Core(TM) i3-4005U CPU @ 1.70GHz
* 64-bit Support (grep -q ' lm ' /proc/cpuinfo && echo Yes || echo No):
* Hardware Virtualization Support (grep -Eq '(vmx|svm)' /proc/cpuinfo && echo Yes || echo No):
* Load average (uptime):
      00:50:31 up 33 min,  1 user,  load average: 1.37, 1.83, 1.57
* Pressure Stall Information (grep -R . /proc/pressure/):
     /proc/pressure/io:some avg10=2.40 avg60=1.58 avg300=1.90 total=124161885
     /proc/pressure/io:full avg10=2.07 avg60=1.19 avg300=1.31 total=86104084
     /proc/pressure/cpu:some avg10=0.15 avg60=1.18 avg300=2.05 total=48147175
     /proc/pressure/cpu:full avg10=0.00 avg60=0.00 avg300=0.00 total=0
     /proc/pressure/memory:some avg10=0.00 avg60=0.00 avg300=0.00 total=0
     /proc/pressure/memory:full avg10=0.00 avg60=0.00 avg300=0.00 total=0
* Memory usage (free -m):
                    total        used        free      shared  buff/cache   available
     Mem:            7848        1911        3685         435        2251        5240
     Swap:          15731           0       15731
* ZRAM usage (zramctl --output-all):
     /dev/zram0     7.7G   4K   80B lzo-rle         4          0   12K        0B      12K       0B [SWAP]
* Top 5 CPU hogs (ps axuScnh | awk '$2!=4132' | sort -rnk3 | head -5):
         1000    2262 48.2  5.7 3893408 460848 ?      Sl   00:22  13:34 firefox
         1000    2433 15.7  2.7 2923316 220420 ?      Sl   00:22   4:23 Isolated Web Co
         1000    1453  8.9  2.5 4400020 208488 ?      Sl   00:19   2:43 gnome-shell
         1000    1357  8.7  1.1 547180 89040 tty1     Sl   00:19   2:41 Xorg
            2     859  7.7  0.1 319524  8888 ?        Ssl  00:17   2:31 rngd
* Top 5 Memory hogs (ps axuScnh | sort -rnk4 | head -5):
         1000    2262 48.2  5.7 3893408 460848 ?      Sl   00:22  13:34 firefox
         1000    2433 15.7  2.7 2923316 220420 ?      Sl   00:22   4:23 Isolated Web Co
         1000    1453  8.9  2.5 4400020 208488 ?      Sl   00:19   2:43 gnome-shell
         1000    2942  6.6  2.4 2913880 200164 ?      Sl   00:37   0:52 Isolated Web Co
         1000    3582  1.2  2.3 2789700 190392 ?      Sl   00:44   0:04 Isolated Web Co
* Disk space usage (df -hT):
     Filesystem                              Type      Size  Used Avail Use% Mounted on
     devtmpfs                                devtmpfs  4.0M     0  4.0M   0% /dev
     tmpfs                                   tmpfs     3.9G     0  3.9G   0% /dev/shm
     tmpfs                                   tmpfs     1.6G  1.9M  1.6G   1% /run
     /dev/mapper/fedora_localhost--live-root ext4      148G   74G   67G  53% /
     tmpfs                                   tmpfs     3.9G  4.0K  3.9G   1% /tmp
     /dev/sda7                               ext4      943M  276M  603M  32% /boot
     tmpfs                                   tmpfs     785M   68K  785M   1% /run/user/1000
* Block devices (without results: "blkid" AND "/sbin/blkid"):

* PCI devices (lspci -nn):
     00:00.0 Host bridge [0600]: Intel Corporation Haswell-ULT DRAM Controller [8086:0a04] (rev 0b)
     00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b)
     00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 0b)
     00:04.0 Signal processing controller [1180]: Intel Corporation Haswell-ULT Thermal Subsystem [8086:0a03] (rev 0b)
     00:14.0 USB controller [0c03]: Intel Corporation 8 Series USB xHCI HC [8086:9c31] (rev 04)
     00:16.0 Communication controller [0780]: Intel Corporation 8 Series HECI #0 [8086:9c3a] (rev 04)
     00:1b.0 Audio device [0403]: Intel Corporation 8 Series HD Audio Controller [8086:9c20] (rev 04)
     00:1c.0 PCI bridge [0604]: Intel Corporation 8 Series PCI Express Root Port 1 [8086:9c10] (rev e4)
     00:1c.2 PCI bridge [0604]: Intel Corporation 8 Series PCI Express Root Port 3 [8086:9c14] (rev e4)
     00:1c.3 PCI bridge [0604]: Intel Corporation 8 Series PCI Express Root Port 4 [8086:9c16] (rev e4)
     00:1f.0 ISA bridge [0601]: Intel Corporation 8 Series LPC Controller [8086:9c45] (rev 04)
     00:1f.2 SATA controller [0106]: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] [8086:9c03] (rev 04)
     00:1f.3 SMBus [0c05]: Intel Corporation 8 Series SMBus Controller [8086:9c22] (rev 04)
     00:1f.6 Signal processing controller [1180]: Intel Corporation 8 Series Thermal [8086:9c24] (rev 04)
     02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5286 PCI Express Card Reader [10ec:5286] (rev 01)
     02:00.2 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller [10ec:8136] (rev 06)
     03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
* USB devices (lsusb):
     Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
     Bus 001 Device 004: ID 04f2:b52b Chicony Electronics Co., Ltd USB2.0 VGA UVC WebCam
     Bus 001 Device 003: ID 0bda:b721 Realtek Semiconductor Corp. Bluetooth Radio 
     Bus 001 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
     Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
* DRM Information (journalctl -k -b | grep -o 'kernel:.*drm.*$' | cut -d ' ' -f 2- ):
     ACPI: bus type drm_connector registered
     [drm] Initialized i915 1.6.0 20201103 for 0000:00:02.0 on minor 0
     fbcon: i915drmfb (fb0) is primary device
     i915 0000:00:02.0: [drm] fb0: i915drmfb frame buffer device
* Xorg modules (grep LoadModule /var/log/Xorg.0.log ~/.local/share/xorg/Xorg.0.log | cut -d \" -f 2 | xargs):
     glx modesetting fbdev vesa fbdevhw glamoregl fb libinput
* GL Support (glxinfo | grep -E "OpenGL version|OpenGL renderer"):
     OpenGL renderer string: Mesa Intel(R) HD Graphics 4400 (HSW GT2)
     OpenGL version string: 4.6 (Compatibility Profile) Mesa 22.2.2
* Xorg errors (grep '^\[.*(EE)' /var/log/Xorg.0.log ~/.local/share/xorg/Xorg.0.log | cut -d ':' -f 2- ):
     [   158.414] (EE) open /dev/fb0: Permission denied
* Kernel buffer tail (dmesg | tail):
     [   66.467162] wlp3s0: associated
     [   66.729924] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
     [   69.977833] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
     [   72.894676] L1TF CPU bug present and SMT on, data leak possible. See CVE-2018-3646 and for details.
     [   72.974660] rtsx_pci 0000:02:00.0: VPD access failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update
     [   72.982668] r8169 0000:02:00.2: invalid VPD tag 0x00 (size 0) at offset 0; assume missing optional EEPROM
     [  183.829385] Bluetooth: RFCOMM TTY layer initialized
     [  183.829407] Bluetooth: RFCOMM socket layer initialized
     [  183.829433] Bluetooth: RFCOMM ver 1.11
     [  189.634754] rfkill: input handler disabled
* Last few reboots (last -x -n10 reboot runlevel):
     runlevel (to lvl 3)   6.0.7-301.fc37.x Tue Nov 15 00:18   still running
     reboot   system boot  6.0.7-301.fc37.x Tue Nov 15 00:17   still running
     reboot   system boot  6.0.7-301.fc37.x Tue Nov 15 00:12 - 00:15  (00:03)
     runlevel (to lvl 3)   6.0.7-301.fc37.x Mon Nov 14 18:17 - 00:10  (05:53)
     reboot   system boot  6.0.7-301.fc37.x Mon Nov 14 18:16 - 00:10  (05:54)
     runlevel (to lvl 3)   6.0.7-301.fc37.x Mon Nov 14 10:48 - 14:53  (04:05)
     reboot   system boot  6.0.7-301.fc37.x Mon Nov 14 10:47 - 14:53  (04:06)
     reboot   system boot  6.0.7-301.fc37.x Mon Nov 14 09:57 - 10:00  (00:03)
     runlevel (to lvl 3)   6.0.7-301.fc37.x Mon Nov 14 09:15 - 09:56  (00:40)
     reboot   system boot  6.0.7-301.fc37.x Mon Nov 14 09:14 - 09:56  (00:41)
     wtmp begins Wed May 15 02:42:11 2019
* DNF Repositories (dnf repolist):
     repo id                        repo name
     fedora                         Fedora 37 - x86_64
     fedora-modular                 Fedora Modular 37 - x86_64
     rpmfusion-free                 RPM Fusion for Fedora 37 - Free
     rpmfusion-free-updates         RPM Fusion for Fedora 37 - Free - Updates
     rpmfusion-nonfree              RPM Fusion for Fedora 37 - Nonfree
     rpmfusion-nonfree-updates      RPM Fusion for Fedora 37 - Nonfree - Updates
     updates                        Fedora 37 - x86_64 - Updates
     updates-modular                Fedora Modular 37 - x86_64 - Updates
* DNF Extras (dnf -C list extras):
     Last metadata expiration check: 0:04:12 ago on Tue 15 Nov 2022 12:46:24 AM +03.
     Extra Packages
     adobe-release-x86_64.noarch                 1.0-1                                  @System                
     adwaita-qt4.x86_64                          1.1.3-4.fc33                           @fedora                
     clang5.0-libs.x86_64                        5.0.1-6.fc30                           @fedora                
     clang6.0-libs.x86_64                        6.0.1-8.fc30                           @fedora                
     codium.x86_64                                            @System                
     compat-ffmpeg28.x86_64                      2.8.20-1.fc36                          @rpmfusion-free-updates
     compat-giflib.x86_64                        4.1.6-1.fc28                           @fedora                
     compat-openssl10.x86_64                     1:1.0.2o-11.fc33                       @fedora                
     fipscheck-lib.x86_64                        1.5.0-8.fc32                           @fedora                
     fwupdate-efi.x86_64                         11-4.fc29                              @fedora                
     fwupdate-libs.x86_64                        11-4.fc29                              @fedora                
     gamin.x86_64                                0.1.10-37.fc33                         @fedora                
     gimp-gap.x86_64                             2.7.0-20.GITb17f908.fc29               @fedora                
     gnome-code-assistance.noarch                3.16.1-17.fc32                         @fedora                
     gnome-online-miners.x86_64                  3.34.0-10.fc36                         @fedora                
     gnome-themes.noarch                         2.32.0-21.fc32                         @fedora                
     gstreamer1-plugin-openh264.x86_64           1.13.90-1.fc29                         @fedora-cisco-openh264 
     ipw2100-firmware.noarch                     1.3-29.fc35                            @fedora                
     ipw2200-firmware.noarch                     3.1-22.fc35                            @fedora                
     jackson-module-mrbean.noarch                2.11.4-2.fc34                          @fedora                
     jai-imageio-core.noarch                     1.2-0.24.20100217cvs.fc29              @fedora                
     java-openjdk.x86_64                         1:             @updates               
     java-openjdk-devel.x86_64                   1:             @updates               
     java-openjdk-headless.x86_64                1:             @updates               
     julietaula-montserrat-base-web-fonts.noarch 1:7.210-5.fc35                         @fedora                
     julietaula-montserrat-fonts-common.noarch   1:7.210-5.fc35                         @fedora                
     khmeros-fonts-common.noarch                 5.0-30.fc33                            @fedora                
     kyotocabinet-libs.x86_64                    1.2.78-1.fc33                          @updates               
     libblockdev-vdo.x86_64                      2.24-2.fc32                            @updates               
     libgit2_0.27.x86_64                         0.27.8-2.fc31                          @fedora                
     libicu67.x86_64                             67.1-2.fc35                            @fedora                
     libquvi.x86_64                              0.9.4-16.fc32                          @fedora                
     libzapojit.x86_64                           0.0.3-21.fc35                          @updates               
     llvm5.0-libs.x86_64                         5.0.1-11.fc32                          @fedora                
     llvm6.0-libs.x86_64                         6.0.1-10.fc32                          @fedora                
     ming.x86_64                                 0.4.9-0.9.20181112git5009802.fc34      @fedora                
     mozilla-openh264.x86_64                     1.7.0-6.fc29                           @fedora-cisco-openh264 
     mozjs38.x86_64                              38.8.0-11.fc30                         @fedora                
     mozjs52.x86_64                              52.9.0-8.fc33                          @fedora                
     mozjs60.x86_64                              60.9.0-7.fc33                          @fedora                
     nautilus-sendto.x86_64                      1:3.8.6-9.fc33                         @fedora                
     netcf-libs.x86_64                           0.2.8-19.fc35                          @fedora                
     openh264.x86_64                             1.7.0-6.fc29                           @fedora-cisco-openh264 
     oprofile.x86_64                             1.3.0-1.fc29                           @updates               
     pangox-compat.x86_64                        0.0.2-15.fc31                          @fedora                
     python2-babel.noarch                        2.8.1-1.fc33                           @updates               
     python2-jinja2.noarch                       2.11.3-1.fc33                          @updates               
     python2-markupsafe.x86_64                   1.1.1-7.fc33                           @fedora                
     python2-numpy.x86_64                        1:1.16.4-10.fc33                       @fedora                
     python2-olefile.noarch                      0.46-12.fc33                           @fedora                
     python2-pillow.x86_64                       6.2.2-5.fc33                           @updates               
     python2-pytz.noarch                         2020.5-1.fc33                          @updates               
     python2-setuptools.noarch                   41.2.0-4.fc34                          @fedora                
     python2-six.noarch                          1.15.0-2.fc33                          @fedora                
     tabish-eeyek-fonts.noarch                   1.0-13.fc29                            @fedora                
     wireless-tools.x86_64                       1:29-28.fc35                           @fedora                
     xemacs-filesystem.noarch                    21.5.34-41.20200331hge2ac728aa576.fc35 @fedora                
* Last 20 packages installed (rpm -qa --nodigest --nosignature --last | head -20):
     libxcrypt-4.4.30-3.fc37.i686                  Mon 14 Nov 2022 09:49:40 AM +03
     systemd-rpm-macros-251.8-586.fc37.noarch      Mon 14 Nov 2022 09:49:39 AM +03
     systemd-libs-251.8-586.fc37.i686              Mon 14 Nov 2022 09:49:39 AM +03
     rust-srpm-macros-23-1.fc37.noarch             Mon 14 Nov 2022 09:49:39 AM +03
     rubygem-listen-3.7.1-1.fc37.noarch            Mon 14 Nov 2022 09:49:39 AM +03
     rpmfusion-nonfree-release-37-1.noarch         Mon 14 Nov 2022 09:49:39 AM +03
     rpmfusion-free-release-37-1.noarch            Mon 14 Nov 2022 09:49:39 AM +03
     python3-libxml2-2.10.3-2.fc37.x86_64          Mon 14 Nov 2022 09:49:39 AM +03
     libxml2-2.10.3-2.fc37.i686                    Mon 14 Nov 2022 09:49:39 AM +03
     ibus-gtk4-1.5.27-4.fc37.x86_64                Mon 14 Nov 2022 09:49:39 AM +03
     libxcrypt-devel-4.4.30-3.fc37.x86_64          Mon 14 Nov 2022 09:49:38 AM +03
     libxcrypt-compat-4.4.30-3.fc37.x86_64         Mon 14 Nov 2022 09:49:38 AM +03
     systemd-udev-251.8-586.fc37.x86_64            Mon 14 Nov 2022 09:49:37 AM +03
     systemd-oomd-defaults-251.8-586.fc37.noarch   Mon 14 Nov 2022 09:49:36 AM +03
     xmlsec1-openssl-1.2.34-4.fc37.x86_64          Mon 14 Nov 2022 09:49:35 AM +03
     xmlsec1-nss-1.2.34-4.fc37.x86_64              Mon 14 Nov 2022 09:49:35 AM +03
     systemd-container-251.8-586.fc37.x86_64       Mon 14 Nov 2022 09:49:35 AM +03
     python3-rpm-macros-3.11-5.fc37.noarch         Mon 14 Nov 2022 09:49:35 AM +03
     libxml2-devel-2.10.3-2.fc37.x86_64            Mon 14 Nov 2022 09:49:35 AM +03
     xorg-x11-server-Xorg-1.20.14-9.fc37.x86_64    Mon 14 Nov 2022 09:49:34 AM +03
* EFI boot manager output (without results: "efibootmgr -v"):
1 Like

I run journalctl -b -1 -r

1 Like

I have modified on
/etc/gdm/custom.conf and uncomment “waylandenable=false”
and it works gdm and login screen. What is the problem?

1 Like

this is file /usr/lib/udev/rules.d/61-gdm-rules

# identify virtio graphics cards to find passthrough setups
SUBSYSTEM!="virtio", GOTO="gdm_virtio_device_end"
ACTION!="add", GOTO="gdm_virtio_device_end"
ATTR{vendor}=="0x1af4", ATTR{device}=="0x0010", RUN+="/usr/bin/touch /run/udev/gdm-machine-has-virtual-gpu", ENV{GDM_MACHINE_HAS_VIRTUAL_GPU}="1", GOTO="gdm_virtio_device_end"

SUBSYSTEM!="pci", GOTO="gdm_pci_device_end"
ACTION!="bind", GOTO="gdm_pci_device_end"

# identify virtio graphics cards to find passthrough setups
# cirrus
ATTR{vendor}=="0x1013", ATTR{device}=="0x00b8", ATTR{subsystem_vendor}=="0x1af4", ATTR{subsystem_device}=="0x1100", RUN+="/usr/bin/touch /run/udev/gdm-machine-has-virtual-gpu", ENV{GDM_MACHINE_HAS_VIRTUAL_GPU}="1", GOTO="gdm_pci_device_end"
# vga
ATTR{vendor}=="0x1b36", ATTR{device}=="0x0100", RUN+="/usr/bin/touch /run/udev/gdm-machine-has-virtual-gpu", ENV{GDM_MACHINE_HAS_VIRTUAL_GPU}="1", GOTO="gdm_pci_device_end"
# qxl
ATTR{vendor}=="0x1234", ATTR{device}=="0x1111", RUN+="/usr/bin/touch /run/udev/gdm-machine-has-virtual-gpu", ENV{GDM_MACHINE_HAS_VIRTUAL_GPU}="1", GOTO="gdm_pci_device_end"

# disable Wayland on Hi1710 chipsets
ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", GOTO="gdm_disable_wayland"

# disable Wayland on Matrox chipsets
ATTR{vendor}=="0x102b", ATTR{device}=="0x0522", GOTO="gdm_disable_wayland"
ATTR{vendor}=="0x102b", ATTR{device}=="0x0524", GOTO="gdm_disable_wayland"
ATTR{vendor}=="0x102b", ATTR{device}=="0x0530", GOTO="gdm_disable_wayland"
ATTR{vendor}=="0x102b", ATTR{device}=="0x0532", GOTO="gdm_disable_wayland"
ATTR{vendor}=="0x102b", ATTR{device}=="0x0533", GOTO="gdm_disable_wayland"
ATTR{vendor}=="0x102b", ATTR{device}=="0x0534", GOTO="gdm_disable_wayland"
ATTR{vendor}=="0x102b", ATTR{device}=="0x0536", GOTO="gdm_disable_wayland"
ATTR{vendor}=="0x102b", ATTR{device}=="0x0538", GOTO="gdm_disable_wayland"

# disable Wayland on aspeed chipsets
ATTR{vendor}=="0x1a03", ATTR{device}=="0x2010", GOTO="gdm_disable_wayland"
ATTR{vendor}=="0x1a03", ATTR{device}=="0x2000", GOTO="gdm_disable_wayland"


# disable Wayland if modesetting is disabled
KERNEL!="card[0-9]*", GOTO="gdm_nomodeset_end"
SUBSYSTEM!="drm", GOTO="gdm_nomodeset_end"
ENV{GDM_MACHINE_HAS_VIRTUAL_GPU}!="1", RUN+="/usr/bin/touch /run/udev/gdm-machine-has-hardware-gpu"
# but keep it enabled for simple framebuffer drivers
DRIVERS=="simple-framebuffer", GOTO="gdm_nomodeset_end"
IMPORT{cmdline}="nomodeset", GOTO="gdm_disable_wayland"

# The vendor nvidia driver has multiple modules that need to be loaded before GDM can make an
# informed choice on which way to proceed, so force GDM to wait until NVidia's modules are
# loaded before starting up.
KERNEL!="nvidia", GOTO="gdm_nvidia_end"
SUBSYSTEM!="module", GOTO="gdm_nvidia_end"
ACTION!="add", GOTO="gdm_nvidia_end"
RUN+="/usr/bin/touch /run/udev/gdm-machine-has-vendor-nvidia-driver"

# Check if suspend/resume services necessary for working wayland support is available
TEST{0711}!="/usr/bin/", GOTO="gdm_disable_wayland"
TEST{0711}!="/usr/lib/systemd/system-sleep/nvidia", GOTO="gdm_disable_wayland"
IMPORT{program}="/bin/sh -c \"sed -e 's/: /=/g' -e 's/\([^[:upper:]]\)\([[:upper:]]\)/\1_\2/g' -e 's/[[:lower:]]/\U&/g' -e 's/^/NVIDIA_/' /proc/driver/nvidia/params\""
IMPORT{program}="/bin/sh -c 'echo NVIDIA_HIBERNATE=`systemctl is-enabled nvidia-hibernate`'"
ENV{NVIDIA_HIBERNATE}!="enabled", GOTO="gdm_disable_wayland"
IMPORT{program}="/bin/sh -c 'echo NVIDIA_RESUME=`systemctl is-enabled nvidia-resume`'"
ENV{NVIDIA_RESUME}!="enabled", GOTO="gdm_disable_wayland"
IMPORT{program}="/bin/sh -c 'echo NVIDIA_SUSPEND=`systemctl is-enabled nvidia-suspend`'"
ENV{NVIDIA_SUSPEND}!="enabled", GOTO="gdm_disable_wayland"

# If this machine has an internal panel, take note, since it's probably a laptop
# FIXME: It could be "ghost connectors" make this pop positive for some workstations
# in the wild. If so, we may have to fallback to looking at the chassis type from
# dmi data or acpi
KERNEL!="card[0-9]-eDP-*", GOTO="gdm_laptop_check_end"
SUBSYSTEM!="drm", GOTO="gdm_laptop_check_end"
ACTION!="add", GOTO="gdm_laptop_check_end"
RUN+="/usr/bin/touch /run/udev/gdm-machine-is-laptop"

# If this is a hybrid graphics setup, take note
KERNEL!="card[1-9]*", GOTO="gdm_hybrid_graphics_check_end"
KERNEL=="card[1-9]-*", GOTO="gdm_hybrid_graphics_check_end"
SUBSYSTEM!="drm", GOTO="gdm_hybrid_graphics_check_end"
ACTION!="add", GOTO="gdm_hybrid_graphics_check_end"
RUN+="/usr/bin/touch /run/udev/gdm-machine-has-hybrid-graphics"

# If this is a hybrid graphics laptop with vendor nvidia driver default to wayland
# It gives poor performance for multi-monitor, but Xorg fails some multi-monitor
# setups too, and this is what we did in F36.
TEST!="/run/udev/gdm-machine-is-laptop", GOTO="gdm_hybrid_nvidia_laptop_check_end"
TEST!="/run/udev/gdm-machine-has-hybrid-graphics", GOTO="gdm_hybrid_nvidia_laptop_check_end"
TEST!="/run/udev/gdm-machine-has-vendor-nvidia-driver", GOTO="gdm_hybrid_nvidia_laptop_check_end"

# Disable wayland in situation where we're in a guest with a virtual gpu and host passthrough gpu
TEST!="/run/udev/gdm-machine-has-hybrid-graphics", GOTO="gdm_virt_passthrough_check_end"
TEST!="/run/udev/gdm-machine-has-virtual-gpu", GOTO="gdm_virt_passthrough_check_end"
TEST!="/run/udev/gdm-machine-has-hardware-gpu", GOTO="gdm_virt_passthrough_check_end"

# Disable wayland when there are multiple virtual gpus
TEST!="/run/udev/gdm-machine-has-hybrid-graphics", GOTO="gdm_virt_multi_gpu_check_end"
TEST!="/run/udev/gdm-machine-has-virtual-gpu", GOTO="gdm_virt_multi_gpu_check_end"
TEST=="/run/udev/gdm-machine-has-hardware-gpu", GOTO="gdm_virt_multi_gpu_check_end"

# Disable wayland when nvidia modeset is disabled or when drivers are a lower
# version than 470,
# For versions above 470 but lower than 510 prefer Xorg,
# Above 510, prefer Wayland.
KERNEL!="nvidia_drm", GOTO="gdm_nvidia_drm_end"
SUBSYSTEM!="module", GOTO="gdm_nvidia_drm_end"
ACTION!="add", GOTO="gdm_nvidia_drm_end"
# disable wayland if nvidia-drm modeset is not enabled
ATTR{parameters/modeset}!="Y", GOTO="gdm_disable_wayland"
# disable wayland for nvidia drivers versions lower than 470
ATTR{version}=="4[0-6][0-9].*|[0-3][0-9][0-9].*|[0-9][0-9].*|[0-9].*", GOTO="gdm_disable_wayland"
# For nvidia drivers versions Above 510, keep Wayland by default
ATTR{version}=="[5-9][1-9][0-9].*", GOTO="gdm_end"
# For nvidia drivers versions 470-495, prefer Xorg by default


RUN+="/usr/libexec/gdm-runtime-config set daemon PreferredDisplayServer xorg"

RUN+="/usr/libexec/gdm-runtime-config set daemon WaylandEnable false"


1 Like

Can you also get the output of:
inxi -Gx
sudo dnf list installed \*firmware\*


1 Like

inxi -Gx not found.

alsa-sof-firmware.noarch                                                    2.2.2-1.fc37                                                      @fedora 
amd-gpu-firmware.noarch                                                     20221109-143.fc37                                                 @updates
atmel-firmware.noarch                                                       1.3-27.fc37                                                       @fedora 
intel-gpu-firmware.noarch                                                   20221109-143.fc37                                                 @updates
ipw2100-firmware.noarch                                                     1.3-29.fc35                                                       @fedora 
ipw2200-firmware.noarch                                                     3.1-22.fc35                                                       @fedora 
iwl100-firmware.noarch                                                                                            @updates
iwl1000-firmware.noarch                                                     1:                                              @updates
iwl105-firmware.noarch                                                                                           @updates
iwl135-firmware.noarch                                                                                           @updates
iwl2000-firmware.noarch                                                                                          @updates
iwl2030-firmware.noarch                                                                                          @updates
iwl3160-firmware.noarch                                                     1:                                             @updates
iwl3945-firmware.noarch                                                                                           @updates
iwl4965-firmware.noarch                                                                                         @updates
iwl5000-firmware.noarch                                                                                          @updates
iwl5150-firmware.noarch                                                                                            @updates
iwl6000-firmware.noarch                                                                                           @updates
iwl6000g2a-firmware.noarch                                                                                       @updates
iwl6000g2b-firmware.noarch                                                                                       @updates
iwl6050-firmware.noarch                                                                                           @updates
iwl7260-firmware.noarch                                                     1:                                             @updates
iwlax2xx-firmware.noarch                                                    20221109-143.fc37                                                 @updates
libertas-usb8388-firmware.noarch                                            2:20221109-143.fc37                                               @updates
linux-firmware.noarch                                                       20221109-143.fc37                                                 @updates
linux-firmware-whence.noarch                                                20221109-143.fc37                                                 @updates
nvidia-gpu-firmware.noarch                                                  20221109-143.fc37                                                 @updates
zd1211-firmware.noarch                                                      1.5-11.fc37                                                       @fedora

1 Like

Thank you very much, I solved the problem by updating to gnome-shell-43.1-3.fc37.x86_64

It probably suggested that you install inxi. Easy to do then run the command.