Fedora 37 not booting after upgrade


Thanks for your help in advance.

Been using Fedora for about 2 years but I am still a Linux beginner.

I upgraded to F37 from F36 using the software app.

I just followed the “Wizard”.

I got to this page:

See the Google Drive Folder to see screenshots: Upgrade Linux Fedora 37 - Google Drive


I choose the 1st option: F37.

Then I got this page:


After waiting a while, I got this page.

I cannot boot in any Fedora (F37 or F36-all available options on the boot page).

When I use the Fedora (0-Rescue…), I get this.

Now, I back up Home and Roots which are together using a bootable USB with Fedora 37 on it.

I am ready to reinstall. or… what else can I try?

To reinstall without losing data I was going to try this:

Any help, suggestions, how to steps would be greatly appreciated.


when you boot any of the four Fedora kernels listed ( .fc37 and .fc36), what are the messages that you see? You need to press ESC while the wheel is spinning.

BTW, no need to upload the pictures you take onto G. Drive or elsewhere, just paste them here in your text. Maybe first-time users aren’t allowed to do that, but I’ll give you a thumbs up and then you can paste screenshots here.

screenshot #4 shows "Failed to mount boot-efi.mount - /boot/efi". Since this is a dual boot system, maybe Windows messed around with the EFI partition. Did you recently install/upgrade Windows?

In rescue mode, do you get to a console? It says root account locked, but happens if you press enter?

Do you know your system’s partition layout and filesystems? That is important to consider when reinstalling. In essence, you want to make sure that /home is not formatted (can be a subvolume in btrfs or a separate partition).

First of all. Thanks for your help. Much appreciated.

Sadly, the system just let me embed one media. I added pictures and videos to the Google Drive Folder. https://drive.google.com/drive/folders/192AqGyit80Zkkqgpzc6RHKYfW3yObkOc?usp=share_link

I recorded what I see. See video-1, video-2, video-3, and video-4 in G.Drive.

All the boot options (f37 and f36) seem to block at the same place.

As I said, I did the upgrade to F37 using the software program download and install button. When it was time to reboot, the first thing that happened was that I got a message that the BIOS needed to be updated, which I did. but, I did not install Windows or upgrade. Maybe an automatic update of Windows 10.

See: Screenshot-5 & Screenshot-6

When I click continue, here is what I get.

See: Screenshot-7

One more click on Enter to Continue and I get the same thing.

Here are my partitions using a bootable USB with F37 on it.

See: Screenshot-15 & Screenshot-16

I tried to use Rescuzilla File Recovery Tool. Here is what this little program showed me.

See (in order): Screenshot-8 to 14

Help Please

Hello, have you seen my reply?

What graphics card do you have?

Can you try booting with nomodeset? In Grub (the page with the kernel selection), press e and then add nomodeset at the end of the command line.

I tried the nomodeset… nothing special happend.

To solve my problem, I backup /home and /root to an extrenal drive using a bootable live Fedora 37 on a USB.

Then I deleted the partions on my computer that had Fedora on it using Windows Disk Manager.

I extended to C:/ drive.

Updated Windows 10 to Windows 11.

Shrink the C:/ drive to make space to reinstall Fedora 37 using the live USB.

Done. I now have dual boot Windows 11 and Fedora 37 working.

Thanks for the help.