Poor performance when switching from Wayland to xorg


I just recently joined the Linux platform and so far I am loving the fedora experience. Being new to linux I have encountered several problems, some of which I have been able to find answers to here and on other websites.

The problem that I am facing right now is related to switching from Wayland to xorg. One of the first things I did when starting out with Fedora was installing the Nvidia proprietary drivers (since I am using a Nvidia GPU), and this fixed the problem of having really poor graphical performance.

When I log in and use Wayland, the nvidia drivers work perfectly and the performance is blazingly fast. However, when switching to use xorg, the performance is terrible - probably identical to that which I had prior to installing the Nvidia drivers.

This makes me think that perhaps there is some problem with xorg using the nvidia proprietary drivers, but I am compleetly clueless here. I have checked the status of the nvidia drivers and ensured that they’re installed and running properly, so I am clueless as to what could be the problem at hand. So, I wonder:

  1. do I need to modify the xorg config file, and if so how?
  2. do I need to install other nvidia drivers? (I guess no).
  1. Probably not, though we need more info to be certain.

  2. We cannot know without knowing what has been installed and from where.

Please post the output of inxi -Fzxx and dnf list installed \*nvidia\* (as text, copied and pasted) using the </> button on the toolbar so we may see the data exactly as formatted on your screen.

What procedure did you use to install the nvidia drivers? Were they installed from the rpmfusion repo or by following directions from some other location?

Hello @banane ,
Pardon my ignorance, but if Wayland is working, why would you want to switch to technology that is on life support?


Just so you are aware. With the release of the next version of fedora (41) the current plan is to remove X11 from the install media. This means that it is quickly going away and as long as wayland works for your apps then try not to switch back.

Thanks for taking the time to reply!

Installation procedure: After enabling rpm fusion I ran the sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda command to install the proprietary nvidia drivers.

This was the output ofinxi -Fzxx:

  Kernel: 6.8.11-300.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: GNOME v: 46.2 tk: GTK v: 3.24.42 wm: gnome-shell dm: GDM
    Distro: Fedora Linux 40 (Workstation Edition)
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: ROG STRIX B550-F GAMING (WI-FI) v: Rev X.0x
    serial: <superuser required> part-nu: SKU BIOS: American Megatrends v: 1004
    date: 08/13/2020
  Info: 6-core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+
    rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 32 MiB
  Speed (MHz): avg: 2336 high: 3700 min/max: 2200/4650 boost: enabled cores:
    1: 2196 2: 2377 3: 2192 4: 2200 5: 3700 6: 2200 7: 2200 8: 2200 9: 2196
    10: 2182 11: 2200 12: 2200 bogomips: 88633
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ASUSTeK driver: nvidia
    v: 550.78 arch: Pascal pcie: speed: 5 GT/s lanes: 16 ports: active: none
    off: DP-1 empty: DVI-D-1,DVI-D-2,HDMI-A-1 bus-ID: 08:00.0
    chip-ID: 10de:1c82
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: gnome-shell driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch display-ID: 0
  Monitor-1: DP-1 model: ASUS VG34V res: 3440x1440 dpi: 110
    diag: 864mm (34")
  API: OpenGL v: 4.6.0 vendor: nvidia v: 550.78 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
    display-ID: :0.0
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: NVIDIA GP107GL High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 08:00.1 chip-ID: 10de:0fb9
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.4 chip-ID: 1022:1487
  Device-3: Focusrite-Novation Scarlett Solo (3rd Gen.)
    driver: snd-usb-audio type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
    bus-ID: 3-2:2 chip-ID: 1235:8211
  API: ALSA v: k6.8.11-300.fc40.x86_64 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: speed: 5 GT/s
    lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2723
  IF: wlp6s0 state: up mac: <filter>
  Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
    pcie: speed: 5 GT/s lanes: 1 port: N/A bus-ID: 07:00.0 chip-ID: 8086:15f3
  IF: enp7s0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-5:3 chip-ID: 8087:0029
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
  Local Storage: total: 2.79 TiB used: 25.31 GiB (0.9%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 990 PRO 2TB size: 1.82 TiB
    speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 33.9 C
  ID-2: /dev/nvme1n1 vendor: Corsair model: MP400 size: 931.51 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 26.9 C
  ID-3: /dev/sda vendor: Kingston model: DataTraveler 3.0 size: 57.66 GiB
    type: USB rev: 3.2 spd: 5 Gb/s lanes: 1 serial: <filter>
  ID-1: / size: 1.82 TiB used: 23.99 GiB (1.3%) fs: btrfs dev: /dev/dm-0
    mapped: luks-7cb40fa4-e092-48ac-a654-29bb3a59200e
  ID-2: /boot size: 973.4 MiB used: 385.6 MiB (39.6%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /home size: 1.82 TiB used: 23.99 GiB (1.3%) fs: btrfs dev: /dev/dm-0
    mapped: luks-7cb40fa4-e092-48ac-a654-29bb3a59200e
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 37.8 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB available: 15.49 GiB used: 3.82 GiB (24.6%)
  Processes: 1066 Power: uptime: 5m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 19 Compilers: gcc: 14.1.1 Shell: Zsh v: 5.9
    running-in: gnome-terminal inxi: 3.3.34

And this was the output of dnf list installed \*nvidia\*:

Installed Packages
akmod-nvidia.x86_64                         3:550.78-1.fc40   @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.8.11-300.fc40.x86_64.x86_64   3:550.78-1.fc40   @@commandline                   
nvidia-gpu-firmware.noarch                  20240513-1.fc40   @updates                        
nvidia-modprobe.x86_64                      3:550.78-1.fc40   @rpmfusion-nonfree-nvidia-driver
nvidia-persistenced.x86_64                  3:550.78-1.fc40   @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                      3:550.78-1.fc40   @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                  3:550.78-1.fc40   @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64             3:550.78-1.fc40   @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64        3:550.78-1.fc40   @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64          3:550.78-1.fc40   @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64             3:550.78-1.fc40   @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64            3:550.78-1.fc40   @rpmfusion-nonfree-nvidia-driver

I wanted to automate some tasks related to starting applications and putting them in different workspaces at system startup with a script, and found out I could use wmctrl to help me in the process of doing this, however it is not really compatible with Wayland. On xorg, wmctrl works fine.

Okay, thanks for the heads up! I’ll stick to Wayland :slight_smile: