[Poll] Do you use Silverblue as main?

My big fear was that this system (silverblue) was unusable (not fully manageable) in comparaison with other classic distrubutions but it has her advantages/disadvantages.

And I just remarked (on YouTube) some trolls between you and Alex :D. So you’re the famous Refi he was talking about in his videos :D.

Silverblue 30 beta on XPS 13 (ver9343) as main. The slow flatpak download (Location: Australia) and rpm-ostree machinery is annoying to no end. Coming from F29 workstation and Debian testing I try to catch up by reading all Silverblue Guide’s I can come across.
I give it a few more weeks before judgement day. Day to day usability is a breaking point e.g. the long terminal command to run a flatpak is a no go. For now I put aliases in my .bashrc file.
What type of users is Silverblue aimed for?
To do my data analysis work I use neovim, LaTex, Python3 & MATLAB. If I can get a workflow with these in Silverblue’s landscape of Containers - Flatpak - Package Layering, then I stay.

If /var/lib/flatpak/exports/bin is in your path then you can use just the app ID.

You mostly can if you use toolbox, which sets up a container with a traditional Fedora Workstation install. That way you can use a normal development workflow but it’s isolated from your host system.

@refi64: I’ve tried today to install silverblue (not on a virtual machine) and I got an error during the installation : installation exited due to error -6 (impossible to mount environnement …). I think it was due to the silverblue ISO but no issue observed on a virtual machine with the same ISO ! I had a dual boot (windows / fedora 29 workstation) but I’ve deleted F29 partition but the grub stays (asking me to choose between windows and F29 even if F29 has completely been deleted). So I think the installation issue is due to the grub from the previous F29 because no issue on a virtual machine (where no grub was present there).I’ll start with deleting fedora’s GRUB from windows. It was btw a fatal error ! Thanks for helping .

Did you do manual or auto partitioning? If the former, did you elect to auto create them and then edit them?

I’ve seen something like this come up quite a few times, I should probably look into it a bit more…

@refi64 I’ve created an empty disk space on Windows, then I’ve installed (auto) silverblue on the empy disk space (like I did with the previous F29 workstation without any issue). I didn’t edit anything (just let the anaconda installation install the OS on the empty disk space). I’ll try to delete the GRUB first (from windows) and then try it again because no issue observed on a virtual machine and that’s (GRUB) the only difference there is between my host and the virtual machine ! I’ve found this bugzilla report (seems to be the same situation): https://bugzilla.redhat.com/show_bug.cgi?id=1625639

Once installed, even at the command line, most flatpaks have a desktop icon to use if desirable instead of the CLI (flatpak run name.name.name

Definitely for the desktop user, but it is early in the life of it, so some things are still being worked out.

I use Octave as a flatpak for my programming efforts in analyzing system behavior, it works well for me. I use TexStudio for my latex doc’s which is mostly for making manuals for my customers. There is the toolbox pet container, which is a nice way of transitioning into Silverblue. It should be part of the base install. To use it you have to first create a container with toolbox create then enter it with toolbox enter. You can then use DNF as you would in the normal workstation. This toolbox is a Gnome session I think so if you have GUI related programs, they will run in their proper GUI although you have to call them from the CLI.
If toolbox is not installed OOTB for some reason, you can layer it with rpm-ostree install toolbox then do a systemctl reboot to restart the ostree with your newly layered package.

Thanks, I did that. However, the app ID is still longer then the unique app name. For example libreoffice ID is org.libreoffice.LibreOffice with your path solution.
Perhaps I do not know enough about flatpak yet, but it feels like developers of the flatpak nomenclature has made it slightly more complicated then necessary when using an app ID name for something that already has a unique terminal name in generations of Linux distributions.

Thanks for the tip - I try it out now.
Has not found anything in the docs about best practice when it comes to install e.g. an editor in each container or install one editor that can be used cross-containers?
I have still only surface knowledge about container workflow so the answer will probably surface when I know more about it… any advice is very appreciated.

I just use one toolbox container and install everything inside.

I used to be skeptical but I’ve checked it out in a virtual machine and as a growing software developer the container based workflow is pretty sweet and flathub seems to be growing by the day! Plan on installing it tomorrow!

If I’m not mistaken the containers have access to your home directory, so the actual project files will be there, meaning if the editor is available in flatpak you can use that outside of the containers. Of couse I suppose you won’t be able to use any built in compiler/debugger buttons unless you can customize the command it runs to enter the container first.

This is just from what I’ve read, no actual experience with flatpak yet.

Just switched to Silverblue. I used fedora from 18-30.
This is gonna help get me back to parity: How can I use podman to run a wayland app

The fact that I cannot get the package winehq-staging installed due to Silverblue not allowing 32bit libraries and dependencies has made me go back to keeping Silverblue as a VM… for now.

We have come so far with support for nVidia… we can almost taste Windows PC gaming on Linux!

I get such poor performance on 3d games on linux though :frowning: You having better luck?

the repetitive - Error: Failed to synchronize cache for repo ‘fedora-modular’ - when I need to dnf install “package” in a toolbox container make me want to leave Silverblue for a while.
Need to work in a distro that reliably connect to its repositories from all countries and time-zones.

You can install that inside the toolbox, or use Lutris which downloads wine separately.

You can try manually changing your mirrors.

Actually I have great performance on 3D games in Silverblue. If you have an AMD video card, anything that is managed by Steam will work wonderfully.

nVidia on the other hand, once you install the drivers from rpmfusion, you’ll need to blacklist nouveau manually in order for it to start. Otherwise it performs just like Workstation.

I’ve tried using toolbox to install winehq and lutris and nvidia drivers to emulate Workstation… but lutris is unable to grab the video card because it’s already in use by Silverblue.

If there is a way to extend the video card to lutris in toolbox, I am willing to give Silverblue another try.