Playing Videos (Videos app, VLC)

Hi all,

On Asahi, whenever I play videos (avi, mp4 etc.) there is discernible blur in movement on screen. It could be a person walking or a person gesturing while talking; in both cases, the limb movements are blurry. This is the case in the pre-installed Videos app and also on VLC, which I installed. (Videos are local.)

Is this about codecs, hardware acceleration, or some other necromancy?

Thanks.

Aubrey

There is no video codec hardware acceleration yet, that is being actively worked on.
avi and mp4 are container formats encasing the coded video, and are likely not the issue here.
Can you attach the output of ffprobe -loglevel debug [path/to/vid.mp4]?
Are all videos blurry? Are they not blurry when played on other apps (e.g. ffplay, firefox), including QuickTime on macOS?
Edit: can you upload the video file somewhere if possible?

1 Like

Hi Eileen,

Thanks for chipping in. The file is circa 500mb, so too large to upload, I’m afraid. But below is the output to the ffprobe command you mentioned:

Duration: 01:31:09.04, start: 0.000000, bitrate: 729 kb/s
Stream #0:0, 41, 1/25: Video: mpeg4, 1 reference frame (DX50 / 0x30355844), yuv420p(left), 512x384 [SAR 1:1 DAR 4:3], 0/1, 623 kb/s, 25 fps, 25 tbr, 25 tbn
Metadata:
title : Main
Stream #0:1, 87, 1/12000: Audio: mp3 (U[0][0][0] / 0x0055), 48000 Hz, stereo, fltp, 96 kb/s
Metadata:
title : Audio - en
[AVIOContext @ 0xaaab44464870] Statistics: 4571680 bytes read, 4 seeks

I have no idea what any of it means, of course. Can you decode it?

As to your other question, yes, that AVI file (and all other video files) play smoothly on macOS.

Many thanks.

MPEG-4 Part 2 (the video’s codec/compression scheme identified by ‘DX50’) is not one of the patented codecs that Fedora disables (Tree - rpms/ffmpeg - src.fedoraproject.org). There’s some minor conflicts on Fedora regarding the patented codecs (H.264/5) but this one is not one of them, so there shouldn’t be any issues with software decode. Note that there is no hardware support for MPEG-4 at all, so macOS/QuickTime uses software decode too.

But I cannot tell whether the video can be decoded without the source file. Please drop by on Matrix (You're invited to talk on Matrix or https://matrix.to/#/#asahi:fedoraproject.org) or some other public file uploading site. I really need more information here. ‘Blur on movement’ sounds like a classic inter-frame decoding error/delay, but I can’t tell much more.

And, to clarify, can you reproduce the issue when using ffplay or mpv? The blurriness could also come from VLC’s overhead, and the two I listed are the “lighter” media players (ffplay should already be installed).

1 Like

Eileen, I’ve provided screenshots with codec details and the outputs of some testing on ffplay and mpv on Matrix/Element. (I don’t really know how to use Matrix, so I just searched for you and started a discussion that way.) Hope to speak to you there. Thanks for your help.

Update: I’m happy to report these pesky issues are over. This wouldn’t have been possible without the excellent help of @eilny (Eileen Yoon), so all credit goes to her for steering me (like a child) through it. She’s probably best placed to explain what worked and why because I’m a newbie to Linux and I can’t tell a codec from a format, but in the spirit of being helpful (though potentially inaccurate), I did the following:

(1) Install RPMFusion Non-Free (https://rpmfusion.org)
(2) Install VLC Non-Flatpak version using DNF (How to Install VLC Media Player on Fedora 39, 38 Linux - LinuxCapable)
(3) Remove the Flatpak version of VLC

(ffmpeg and mpv were installed for troubleshooting and testing

Playback is still choppy on the standard/default ‘Videos’ app that’s bundled with Asahi Linux, but that’s not a problem because now non-Flatpak VLC works and it’s easy to make VLC the default application for video files.

Now, I can play *.mpv, *.avi, *.mp4 files and they all play smoothly. (I couldn’t tell you which codecs are used in files I’ve tested, but I’ll shelve the discussion of H264/H265 for another day.) For now, everything is working and all is well with the world.

2 Likes