Pgadmin4 installation errors

I have followed this tutorial for installing pgadmin4:

When I run the following command sudo /usr/pgadmin4/bin/ and I get the following error:

Setting up pgAdmin 4 in web mode on a Redhat based platform…
Creating configuration database…
/usr/pgadmin4/bin/ line 64: /usr/pgadmin4/venv/bin/python3: No such file or directory
Error setting up server mode. Please examine the output above.

Any help would be great thanks.

Python virtual environments (venv) are a topic in themselves. That command apparently failed because the script could not create the needed environment under the system directory /usr/pgadmin4.

Most user virtual environments are created under ~/,local/share/ so the user has access to everything there. I have not personally set up pgadmin4 so cannot speak to how it works in that respect.

This link was at the top for a quick search for fedora and pgadmin4

Maybe it can help.

Alright thanks I will give it a try out.

Update realized that I may have had conflicting packages from the rpm and what I had installed from using pip installation. I just removed pgadmin and followed the installation instructions on the page I shared in first post. Now it works