Two issues with pgadmin4 in Fedora Silverblue

Hi all, I’ve successfully layered Fedora Silverblue 32 with PostgreSQL, PstGIS and PgAdmin4 by following these instructions

However, once rebooted, there is no signal of existence of PgAdmin4: the terminal doesn’t recognize the command pgadmin4 or pgadmin and it is not included in the application list in Gnome.

In addition, I was not able to edit the file /usr/lib/python3.8/site-packages/pgadmin4-web/config_distro.conf. Trying with the commands chmod and seteonforce from root in order to change permissions gave no result: I could write inside the file but unable to save it. I tried to edit the file /etc/bashrc with vi but at the order of the Esc command there were no shift in mode, so I couldn’t even write on this file.

According to the mentioned instructions, the config_distro.conf must be reset with these paths:

LOG_FILE = ‘/var/log/pgadmin4/pgadmin4.log’
SQLITE_PATH = ‘/var/lib/pgadmin4/pgadmin4.db’
SESSION_DB_PATH = ‘/var/lib/pgadmin4/sessions’
STORAGE_DIR = ‘/var/lib/pgadmin4/storage’

I do not the real consequences of not having this file configured.

For the rest, I am very enthusiastic with the Silverblue project. I have Jupyter Lab, pandoc and a LaTex editor, which is enough to fulfill my job duties, installed in the default toolbox. And I am discovering every day the vast range of applications of buildah and pandoc. I failed to install PostgreSQL in the toolbox because there is no link to systemd. I am certain about the posibbility of running PostgreSQL from containers, but I made these instalations to learn SQL. In the meantime I am just content to digest a bunch of lessons in plain Linux with this experiment because I am a neophyte, as it can be deduced from this note. Thanks a lot for your attention.

1 Like

It is an amazing project indeed. I also have the same problem. Tried with podman also and had problem too. Still looking for a solution…

1 Like