PDF thumbnails not showing

This is a minor annoyance, but recently I can’t see thumbnails of PDF in the file manager, weirdly, it only happens with recent files, as shown in the attached image. I’m using fedora 35, GNOME, and my default reader for PDFs is okular. Please help.

Is evince-thumbnailer still installed?

Yes it is installed, I tried setting evince as my default PDF viewer to see if it resolved itself, but it didn’t

Sorry I took so long to reply, crazy days

Do you have a lot of thumbnails (enough that the cache might be filling up)? The default maximum size of the thumbnail cache is 512 MB. It is supposed to prune old thumbnails when it is full (not new ones), but who knows. You could try to increase the max size and see if it helps.

I have increased the max size of the cache with dconf-editor as suggested in that article, but no luck

Hi, there a way to regenerate specific thumbnail for one file. But first make sure that file are not encrypted.

Make file touch ~/.local/share/nautilus/scripts/regenerate-thumbnails.sh. Then edit it and add following script:



      touch -m "$FILE"


Make this file executable with chmod +x ~/.local/share/nautilus/scripts/regenerate-thumbnails.sh

Open your nautilus and browse to your file. Select the file, right click, choose Scripts, then click regenerat-thumnails.sh.

Source: here

Hi, I have created the script (btw I thin there’s an error in the the third line, I think its supposed to be IFS=$‘\n’ as per the link, as originally posted it doesn’t do anything) and executed with right click as suggested, but still no effect, all files on which I tested it are still without thumbnails. And when I executed it on a file that previously had the thumbnail, it removed it and now it is also without thumbnail

I edited as you mentioned. My bad on typing. Those ```, must be when I want to create preformatted text with markdown.

In my machine, when run above script, the thumbnail gone a moment then regenerate it self.

You could use dconf-editor then navigate to /org/gnome/desktop/thumbnailers/disable then check if pdf is blacklisted on there. My machine setting are default.

Another place to check (you could read the description on there):

Checking dconf, pdf is not blacklisted, show-image-thumbnails current value is “always” and thumbnail-limit was in 50, I increased to its maximum value of 5000, it had no effect.

Would you like to copy one of the files that doesn’t have the thumbnail to your home folder like /home/your-username/file.pdf and see if the thumbnail are generated on there or not?

I copied both a file that has and one that doesn’t have a thumbnail to my home foler, in both cases the thumbnail is not generated.

1 Like

Thank you for testing it. I just want to make sure that the file are in your local system and not from network sharing or mounted drive/usb.

From nautilus bug report here, there a user give a tips to regenerate only the failed thumbnails with:

rm -rf ~/.cache/thumbnails/fail/gnome-thumbnail-factory/*

If above didn’t solve the problem, maybe If you want, you could also check by creating new user and then directly go to the pdf file directory that failed to generate the thumbnails. If it works with newly created user, it safe to say that all system working fine and there just something not work correctly with your current user (each user have it’s own thumbnail caches)

Hi, executed the command provided, no effect.

I also created a new user, logged in and went to the folder, no thumbnail was generated

try install/reinstall this packages .

libgexiv2 evince-nautilus exiv2 exiv2-libs

evince-nautilus wasn’t installed, so I installed it, no change, then I reinstalled

libgexiv2 evince-nautilus exiv2 exiv2-libs

Still, the thumbnails are not generated

If other thumbnails are properly generated except your pdf files mentioned in this post, you could manually add it.

If you right click the pdf file on nautilus then click Properties, you will notice a box image above Name on pop up windows. Click that image and select manually the image you want as thumbnail.

For creating the thumbnail it self you could use convert -thumbnail x300 test.pdf[0] test.png (notice [0] after pdf file name are the first page of pdf to generate as thumbnail). If you don’t have convert command, on terminal will offer you an app to install.

Use the test.png generated by convert command as your pdf file thumbnail from right click > Properties above.

I used convert as you suggested, and it worked! However the problem is not only those PDFs in the images I’ve attached, but all the new PDFs in my system, or PDFs that I had previously but that I hadn’t visited the folder since I reinstalled the OS.

Since on my system I only have evince as my pdf reader, the only way to replicate your problem is by removing evince.

Look like you already have evince on your system. And if you want to reinstall it, you need to make sure the following packages to reinstall too.

sudo dnf reinstall evince evince-previewer evince-thumbnailer evince-nautilus --allowerasing

From journalctl, look like if we run the script *.sh I shared above, it will trigger man-db-cache-update.service to run.

You could also check this service if there any error messages.

systemctl status man-db-cache-update.service

You could also to force the service to run manually with

systemctl start man-db-cache-update.service

The service will run once and dead again since it’s oneshot type service that after run it will dead.

That’s all I know.

Sadly, none of those commands did any difference.
I also removed okular, to see if that was the problem, no luck.
I also tried dnf remove and then dnf install all the evince packages instead of the reinstall command, still no luck.


I know it’s not what you asked, but you may want to take a look at sushi

It’s a quick preview you can use in nautilus with the spacebar.