"Oh no, something has gone wrong" after upgrade


I did the update and it did work. Downloaded and rebooted. Unfortunately, when rebooting, it now displays “Oh no, something has gone wrong. A problem has occurred and the system can’t recover. Please contact a system administrator.”

Rebooted dozens of times, same issue. What do I do now?

It could be a number of things so we’ll need to debug it a little.

Are you getting to the login manager at all? (I assume this is a Workstation install, or one with Gnome/GDM?)

1 Like

Unfortunately not. Upon other forums I tried Ctrl (+ Alt + F3 but nothing works. I can only select F35 (it broke down during reboot) and then the message appears. Can’t log in anywhere.

So if GDM is crashing, the only change between Fedora 35 and Fedora 36 is that GDM now defaults to Wayland. So that could be causing this. To make it use X11 again, we need to update the configuration file /etc/gdm/custom.conf to comment out the WaylandEnable=False line.

If ctrl + alt + f3 doesn’t work, we can try to boot into text mode to modify the file too.

What do you mean by “I can only select F35”? Does the F35 kernel work?

As in, when booting, only F35 is selectable.
I can only have the grub by pressing c. Doesn’t recognize dnf/sudo.
How do I change whatever file you talked about?

Edit: Tried to find the file w the grub console but couldn’t find it?

This could indicate a failed upgrade. Did the upgrade complete properly?

You’ll need to use grub to boot into text mode. Hopefully that’ll bring you to a tty where you can login and modify the file (if the file is the issue).

I can’t find it in the docs at the moment, but this looks correct:

1 Like


I believe it is a failed upgrade. It was upgrading following reboot and I was on my phone meanwhile, last thing I saw was 57% completed and then at some point that error. So it would indicate that error.

I managed to get the tty however it doesn’t let me login. Says incorrect login, despite I put my username + PC password.

OK, I guess the incorrect login can be selinux related. Can you also add selinux=0 in the grub boot commands to see if that helps?

For completeness: the username at the tty should be the lowercase username that you would see in the terminal, not the “pretty” username that the login manager would show.

1 Like

Nothing. I tried adding it (to boot tty I just added 3 at the end of the Linux line - pressed space and added selinux=0 after the kernel part, but the login is still req’ed)

1 Like

The login will be required—that won’t go away, but if it was selinux causing trouble that would’ve stopped.

If you can’t login there, I’m out of ideas for the moment. Try 1 instead of 3 (single-user instead of multi-user)? (See “rescue.target” here: systemd.special )

Tried w 1:
“You are in rescue mode. After logging in, type ‘journalctl -xb’ to view system logs, “systemctl reboot” to reboot, “systemctl default” or “exit” to boot into default mode.

Cannot open access to console, the root account is locked. See sulogin(8) man page for more details.

Press Enter to continue

(Did that)

Reloading system manager configuration
Starting default target
In red: Failed to start default target: Opération refused, unit may not be isolated”

So the rescue mode doesn’t work because the root password is locked (this is the default).

I can’t tell why your credentials aren’t working, so I’m out of ideas at the moment. Run level 3 should work, but if your credentials aren’t working, we can’t use it.

Ah, thanks nonetheless.

1 Like

I found this quick-doc on how to work on your computer if the root account is locked for when we try 1 to get to the rescue.target. Worth a try?

By any chance, is your root partition full? Did the upgrade fill up the root partition and therefore cause the issue?

1 Like

Unable to see it. But I’d highly doubt it.

Can’t you run df -h in the rescue mode? That should show you the free space on the disc.

A post was split to a new topic: “Oh no something went wrong” after upgrading to F39