OS bricked after upgrade to Fedora 37

, ,

Hey all, I’ve recently tried to perform the upgrade the Fedora 37, but after the process finished I was met with a white error screen that said to contact a system administrator.
If I hard reboot from there, I can get into the grub menu where I see 3 options to boot into different versions of Fedora 36 (all leading to the same error page) or into a recovery mode marked as Fedora 35, which outputs its own set of errors.
I’m attaching a couple of pictures to give a better explanation of the errors in question.

Is there anything I can do to salvage the install or should I wipe the laptop and reinstall Fedora from scratch?

1 Like

Press CRTL+ALT+F3 After booting to the white “oh no!” screen, this should give you a tty with login-prompt. Login, then check dnf distro-sync --releasever=37 dnf check-update dnf update as well as journal output.
Might be something similar to my current issue. See my discussion.

Yep, it does indeed seem like we are in a very similar situation.
I’ve followed what you did in your thread and what I could see in journalctl is the same rpm db migration error from the earlier screenshot, plus an unrecoverable failure in org.gnome.Shell.desktop and org.gnome.SettingsDaemon.Datetime.desktop, which seems to spawn from libsoup just like in your case

it turns out my problem was fixed by removing nodejs and resetting its module.
I ran dnf module provides libnghttp2 , which told me that it came from nodejs:14.
I then ran dnf remove nodejs , dnf module reset nodejs and dnf check-update ; at this point I saw the curl/libcurl updates as well as a new nodejs update to stream 18 (which seems to be the default in Fedora 37).
I ran dnf update and then reboot and now everything works

1 Like

Thank you, Luca . It saved me several hours.

Bug was reported here. Solution is, either reset to Node 18 or update libnghttp2 to latest (now non-module) version.