Fedora 37 won't boot after update yesterday (10.01.22)

Hey guys,

I updated Fedora yesterday and now I get the boot screen loading and when GDM should start my PC just freezes.

I managed to get into the terminal by editing the boot parameters inside grub but so far I couldn’t find any topic here that gave me a fix or any relevant commands to troubleshoot it.

Please help.

Hello @mucan ,
Since you can boot into a terminal you should be able to check the boot log with journalctl -b. There will be lots of output. Let’s see what that gives you then go from there. I personally had other issues at upgrade, but they were solvable.

1 Like

Sorry posting the output with a smartphone is basically impossible. Everything seems normal.

The only thing resembling an error seems to be:
“dbus-broker-launch[1151]: activation request for org. Free desktop.home1 failed: the systemd unit dbus-org.freedesktop.home1.service could not be found”

Also systemd said a little before that

“iscsi.service: unit cannot be reloaded because it is inactive.”

Otherwise it only started that my system clock is off by a few seconds.

Edit: even when I manually start homed and iscsi as soon as I start GDM it freezes again. Maybe I can get more information about the systemd log about GDM

Edit 2: reinstalling all packages did nothing and disabling Wayland only made it so that it does not freeze at GDM and instead crashes to the terminal by default. Also i found out from the terminal i can manually start a desktop session with startx but naturally this is not an optimal solution especially since I’m missing wayland

Edit 3: I hate to be the guy with the edits but i guess they might be important. With “journalctl -u gdm” i found out that I’ve been getting the gdbus error and another one for over a week so that doesn’t seem to be it. The failed boots just list “Starting gdm.service” and “started gdm.service” so i guess systemd thinks it started gdm successfully. I’m 80% sure that the update to gdm 43.0-3 is what broke my gdm but i can’t roll back to test my theory.

You could try downloading from koji, gdm-43.0-2.fc37 | Build Info | koji.

Or if you have koji already installed.
koji download-build --arch=x86_64 gdm-43.0-2.fc37
sudo dnf install ./gdm-43-0.2.fc37

Changes for GDM:

  • Keep F36 behavior for hybrid machines with vendor nvidia
    driver, rather than defaulting to Xorg with wayland as
    an option.
    Resolves: #2128910

  • Allow users with hybrid machines with vendor nvidia driver to
    elect to use the wayland session from the login screen menu.
    Resolves: #2128910

You can also find the history for the upgrade and see what else changed:
sudo dnf history gdm
sudo dnf history info "ID of upgrade event"

Because the changes started in -0.2 you may want to fall back to -0.1

1 Like

Guess my guess was wrong… Now I absolutely don’t know what to do e.g. it seems it was not a regression

I now found the last update before my PC broke. It does not include GDM. It’s mostly mesa, Google fonts, nautilus and pipe wire. I sadly don’t know how to scroll up inside the terminal and the internet doesn’t help so I can’t see everything.

You could pipe the output through less with <command> | less which allows you to scroll up and down in the output from that command. Less is a pager that allows scrolling in a terminal and is standard in linux.

1 Like

Sorry I’m retarded. I’m now inside the x desktop again and here now i can normally scroll through the terminal but the only ones missing were gnome-setting-deamon, geary and ansible-srpm-macros.

Somehow i don’t see any of these breaking my system. Sadly i didn’t make that btrfs snapshot i wanted so i could try to see if it really was the update and not some configuration file or something.

Just out of curiosity, are you experiencing any selinux avc denials? If so you could try sudo fixfiles relabel

I’m facing a similar issue and can only access my system using a live iso and chroot. Did you figure out what’s causing the issue on your end?

Somehow the wayland gdm session didn’t work changing WaylandEnable=false in /etc/gdm/custom.conf did the trick for me.


Just ran into this issue as well. The workaround of @saecki works for me, though.

Does anyone know if the issue is already tracked somewhere? I couldn’t find anything about it elsewhere.

Setting WaylandEnable=false was a workaround for me, but as I have an intel gpu installing intel-media-driver fixed the issue. I think I enabled (or tried to enable) Firefox video accelaration in the past, but never installed intel-media-driver in the past: Firefox Hardware acceleration - Fedora Project Wiki.

Found the idea in arch forum: [SOLVED] GDM failing to start with Wayland since update to 43 / Applications & Desktop Environments / Arch Linux Forums
I haven’t tried to comment out pam_systemd_home or run without gstreamer-vaapi

1 Like

Another thread https://www.reddit.com/r/archlinux/comments/ylnpp1/blank_screen_after_the_new_update_i_cant_even/

Exactly the same problem happened to me and there are other people with the same problem

I’ve upload a bug ticket :https://bugzilla.redhat.com/show_bug.cgi?id=2143276

I updated to Fedora 37 yesterday and GDM wouldn’t load, making the computer unusable (just a black screen).

I couldn’t press Ctrl + Alt + F3 to switch to a TTY, and I couldn’t boot into single user (by putting single at end of the linux grub line) because my root account is disabled, but I could put the number 3 at the end and that booted into a TTY login.

After logging in I ran sudo dnf install intel-media-driver. Rebooting allowed GDM to finally load.

1 Like

I had the same issue and your trick @hashem and @saecki worked for me as well. (setting WaylandEnable=false)


Update to fix this if anyone wants to test

I just got the gnome-shell-43.1-3.fc37 update from the fedora-updates repo, uninstalled intel-media-driver, rebooted, and GDM was able to load successfully :tada:. Thanks for the fix @joe and @jadahl !

1 Like

Thank you very much, I solved the problem by updating to gnome-shell-43.1-3.fc37.x86_64

1 Like