Fedora 37 Beta broken after update


This morning I did some routine updates (from gnome-software) on my fedora 37 beta (upgraded from 36) and after a reboot, gdm doesn’t start, a white screen appears with a “Oh no, Something has gone wrong.” message.
I tried to switch to tty but after inserting the password, the user login prompt reappears.
From chroot I tried to force gdm on x11 and to put nvidia modules into initramfs but without luck.

1 Like

gdm debug log: https://pastebin.com/Qg7mE7M2

1 Like

Please report this to the QA team here:


Fedora 37 is still in beta and so is not yet a supported release. So, this forum is not the best place to discuss it—only testers are recommended to use Beta at this point, to help catch bugs like these.

1 Like

yeah, happened to me a few days ago, was testing Fedora37 on a SteamDeck. That was fun, until that same white screen :slight_smile:
I think I’ll wait just a little before making another attempt at 37

Are you using gnome-patched? I had this same issue and ended up solving it by disabling the repo and using sudo dnf distro-sync to go back to the regular repo version of mutter.