NVIDIA drivers and Wayland

I have installed CUDA, with the related NVIDIA drivers, from here.

After turning off SecureBoot, the drivers seems to have been loaded, but now I’m on X11:


Is there a way to have Wayland back?

I want Wayland back :frowning:

Installing NVIDIA driver means an automatic switch to X11 and nothing more. Back to Wayland: take it back.

1 Like

Historically nvidia has not been compatible with wayland and only uses X.

I understand that limitation is being worked on but do not have an up to date status. IIUC, for now at least, nvidia requires X, nouveau allows either X or wayland.

It looks like this patch was needed which has been merged.

There is a tutorial on enabling Wayland on proprietary NVIDIA drivers but I don’t know if it is safe to use.

You don’t know until it is tried. Someone has to test it in general use. The patch is because the developers think it is ready so maybe it will and maybe it won’t. If it doesn’t then the developers need a bug report so they know it does not work and what is going wrong.

I am not ready to put my daily driver (my only desktop) at risk, but will soon have another to test with.

This Phoronix post says that

Fedora Workstation 35 […] features all of the latest (X)Wayland improvements including support around NVIDIA’s proprietary driver

Does it mean we can have Wayland and NVIDIA proprietary drivers at the same time?

No. I switched to Fedora 35 and still only X11 with NVIDIA proprietary drivers

1 Like

A clean install will allow wayland. An upgrade remains as previously configured.

Will I get Wayland if I remove the drivers and reinstall them?

You could try the instructions here

Yes, No, Maybe.

I am not sure of everything, but the newer nvidia drivers that were tweaked for wayland are (I think) the 495.44 version now available with f35.

It depends on a lot of things, but you should be able to select a wayland session with the gear in the lower right corner of the login screen. All I can suggest is try it. If it works then good, if not then fall back to xorg.

With some hardware and some software wayland seems to work for some F35 users using nvidia but not for others so there are still issues.

I found this on the RPMFusion HowTo Guide.

It looks like we finally have NVIDIA proprietary driver under Wayland with Fedora 35 and NVIDIA >= 495 :partying_face:


NVIDIA works under Wayland (and Xwayland) starting with Fedora 35 and NVIDIA driver 495 and later. With GNOME 41, Wayland can be selected explicitly with GDM.

Please remind that video acceleration with VDPAU isn’t available under Wayland.

Right. That was one of the boosts that was done when 35 was released. However, it is still not 100%.
Some have had issues even now since not everything works with wayland.

Additionally, the 495 driver seems to have dropped support for some of the older cards. Notably it seems, the 700 series and below. The older cards can still be used on 35 by removing the 495 driver and installing the 470xx driver instead. This does, of course, force the user back to xorg and not wayland.