NVIDIA Auto Installer for Fedora now works with Fedora 34

If you install inxi then run “inxi -Gxx” the output will show you if the nvidia driver is in use or its FOSS alternate nouveau.

Also using “lsmod | grep nvidia” will list all the nvidia modules that are active. If the output of this is blank then the nvidia drivers are not loaded.

Thank you, the output of “lsmod | grep nvidia” is blank, in that case what should I do? Thank you very much.

This image is running inxi -g

Great job! Maybe it’s a slightly different issue. Unfortunately, I ran into issues of not finding xorg-x11-drv-nvidia.
When I run sudo nvautoinstall --driver

I got 69d9697c3e00619418f0c1fd285cd8f6a401ea94.png

Then I tried to search xorg-x11-drv-nvidia, it doesn’t have the latest version xorg-x11-drv-nvidia-470 that listed in https://fedora.pkgs.org/34/rpmfusion-nonfree-updates-x86_64/xorg-x11-drv-nvidia-470.63.01-3.fc34.x86_64.rpm.html.

I have updated dnf and non-free repos.

Any comments are much appreciated!

@kayajooks it seems you do not have the nvidia driver installed.

@fredfung It looks the same.

I would do the following, since I am more of hands-on type admin.

  1. Make sure the rpmfusion repos are installed as in Configuration - RPM Fusion
  2. do a full update so you have the latest kernel, then reboot
sudo dnf update -y
  1. install (or reinstall) the drivers.
sudo dnf install akmod-nvidia nvidia* xorg-x11-drv-nvidia*470* --disablerepo=fedora,updates --exclude=nvidia*390*
  1. reboot again so the driver gets loaded

It now should be working with the nvidia driver and “lsmod | grep nvidia” should show the modules in use.

This is all that should need be done. However, if you are using a laptop and are having issues with the display & external monitor not showing correctly then that seems to be fixed by copying /usr/share/X11/xorg.conf.d/nvidia.conf to /etc/X11/xorg.conf.d/nvidia.conf and once again restarting.

Hi @computersavvy , I did everything you recommend but still does not work is there any way to validate if my graphics card is compatible I have a NVIDIA® GeForce® GTX 1650 With Max-Q Design, 4GB GDDR6 in a notebook MSI Prestige 15 A11SCX.

When I reboot I get the message shown in the following image:

I executed some commands indicated by @t0xic0der in the following link

I use Fedora with Cinnamon not Gnome.

1 Like

I also ran the following: sudo “dnf list installed ‘nvidia’”

My problem is that many times my screen freezes others when I do browsing the web pages look bad and some videos stop and the audio continues.

Thank you very much for your help and advice

One more thing to look at.
The kernel is protected from out-of-tree unsigned modules when secure boot is enabled.
Check the bios and make sure secure boot is disabled. That may be the only remaining blocker since all the packages are there and the kmod-nvidia package shows it was built by the system for your kernel.

I assume you verified the booted kernel is 5.13.13 as indicated there.

I just did a new install on a system for a friend and saw the same message but after doing a reinstall of all the packages it then loaded the modules and booted with the nvidia drivers. His was a Dell laptop.

Hi, I checked and indeed the secure boot was active, I disabled it and it booted without the message I ran “lsmod | grep nvidia” and it showed the following

Only in the system information section it appears that the GPU is the intel, should I check something else?

That shows the driver is properly loaded.
Please, in the future do a copy and paste of the screen text into code tags. It is usually easier to read for us and it retains the formatting seen on the screen.
Code tags are done as

Your text here
  1. Did you copy the nvidia.conf file as I suggested earlier?

  2. Do you want the nvidia card to be used 100% of the time.
    if no, then do nothing else.
    if yes, then add 2 lines to the nvidia.conf file in /etc/X11/xorg.conf.d.
    Paste the following in both stanzas within that file.

	Option "Primary" "yes"

Once done and you have restarted the nvidia gpu will become the primary GPU and the intel IGP will be ignored as long as the nvidia drivers are used.

If you do not make it the primary then you can always use it for specific apps by right clicking on the app icon and choosing to start with discrete gpu.

Hi computersavvy. Thank you very much for your help. New to the community so I am much grateful for receiving your prompt reply.

I might be acting silly but I have convinced myself that I have enabled the non-free repos for 34. I list my repolist as below (I have to say it is a bit spaghetti). Still, I have the error xorg-x11-drv-nvidia 470 is not provided. (kernel had updated)

instead of using dnf search try using

dnf list installed '*nvidia*' 

and please post the output in code tags as I explained in post #24 just above instead of using screenshots.

You also have the fedora-modular and updates-modular repos enabled which I have so far refused to use and one of the errors you got was related to that.

You can disable any repo temporarily for a transaction with

--disablerepo <repo name> (once for each repo to disable) when doing a dnf command.
You can also disable them permanently if you wish with

dnf config-manager --disable fedora-modular updates-modular

then they can still be used by selectively enabling them with --enablerepo <repo name> as I showed above with --disablerepo.

I have seen some conflicts between the rpmfusion-nonfree-nvidia-driver repo and other rpmfusion repos so I would suggest that it be permanently disabled while the others are used.

Hi computersavvy. Sorry, I should have paid more attention to your early post about posting code format.

The reason why I used dnf search is that the package xorg-x11-drv-nvidia does not present in the package manager. This issue persists after I include the non-free-update repo which I believe is the source of the driver.

I spawned a fedora workstation VM, in which the desired driver indeed is listed after porting the repo. So, this looks bizarre to me that I could not fetch the package from my native machine.

In order to verify/debug, I have tried you suggestions to disable unused repors. On top of that I’ve taken the following mitigations

  1. dnf remove rpmfusion-nonfree-release-noarch.
  2. checked it is removed from /etc/yum.repos.d
  3. dnf clean all
  4. manually remove the rpmfusion-nonfree* from /var/cache/dnf
  5. reinstall the nonfree repo
  6. checked /etc/dnf/dnf.conf. Looks normal.

Still, the package is not found. For instance, if I do

yum list xorg-x11-drv-navidia
Error: No matching Packages to list

Whereas in the VM, it shows

yum list xorg-x11-drv-navidia
Available Packages
xorg-x11-drv-nvidia.x86_64                            3:470.63.01-3.fc34                             rpmfusion-nonfree-updates

My question is, is that possible to prevent dnf from fetching packages?

The major difference between my native machine and the VM is the kernel versions. The former is on 5.13.8, the latter is on 5.13.14. That said, I don’t think the kernel is the culprit for such issue.

Hi, thanks for your help, I tried point 2 but still the Nvidia GPU does not appear as default, I copied the content of the file nvidia.conf:

#This file is provided by xorg-x11-drv-nvidia
#Do not edit
Section "OutputClass"
        Identifier "nvidia"
        MatchDriver "nvidia-drm"
        Driver "nvidia"
        Option "AllowEmptyInitialConfiguration"
        Option "SLI" "Auto"
        Option "BaseMosaic" "on"
        **Option "Primary" "yes"**

Section "ServerLayout"
        Identifier "layout"
        Option "AllowNVIDIAGPUScreens"
        **Option "Primary" "yes"**

Is the way I did it correct?


You should not have the ** entries on those lines
They should read

Option "Primary" "yes"
**Option "Primary" "yes"**

Also, try using dnf instead of yum.
This should work (use sudo if not doing that as root)

dnf list installed '*nvidia*'

and you can just copy/paste that command into your command line.
Then please post the entire output here.

Remember that conflicting repos can cause problems and your error messages above indicate a modular conflict. You may need to fix that first.

Try doing “dnf clean all” and “dnf update --refresh” before you do anything more with the drivers on your host machine.

Although they can be installed, the VM can never load the nvidia drivers since it only uses a virtual GPU and not a physical one.

Also, I cannot be more detailed in the response since you never post the screen output of the commands used nor the response seen. Without the detailed info it is difficult to guess exactly where your error appears or what it is. The more info you provide the more help is possible.

@fredfung, Please check this writeup mbrancaleoni/erlang.

@kayajooks, could you please check once if the secure boot is turned off?

Hi JV, my file is not with the ** that is done by this blog if you try strong text on the other side over the command:

dnf list installed '*nvidia*'

The answer I put it in other post but

[cs@lh ~]$ dnf list installed '*nvidia*'
Installed Packages
akmod-nvidia.x86_64                        3:470.63.01-1.fc34 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-5.13.13-200.fc34.x86_64.x86_64 3:470.63.01-1.fc34 @@commandline     
kmod-nvidia-5.13.14-200.fc34.x86_64.x86_64 3:470.63.01-1.fc34 @@commandline     
nvidia-modprobe.x86_64                     3:470.63.01-1.fc34 @rpmfusion-nonfree-nvidia-driver
nvidia-persistenced.x86_64                 3:470.63.01-1.fc34 @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                     3:470.63.01-1.fc34 @rpmfusion-nonfree-nvidia-driver
nvidia-xconfig.x86_64                      3:470.63.01-1.fc34 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                 3:470.63.01-3.fc34 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64            3:470.63.01-3.fc34 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64       3:470.63.01-3.fc34 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-devel.x86_64           3:470.63.01-3.fc34 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64         3:470.63.01-3.fc34 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64            3:470.63.01-3.fc34 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64           3:470.63.01-3.fc34 @rpmfusion-nonfree-nvidia-driver

When you refer to YUM I think you are confusing me with the user Fred Funng @fredfung

Kind Regards

Hi @t0xic0der I checked, and the secure boot is disabled, it still shows the intel card as the default.

[cs@lh ~]$ inxi -G
Graphics:  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel 
           Device-2: NVIDIA TU117M driver: nvidia v: 470.63.01 
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 
           1: 1920x1080~60Hz 2: 1080x1920~60Hz 
           OpenGL: renderer: llvmpipe (LLVM 12.0.1 256 bits) v: 4.5 Mesa 21.1.7 
[cs@lh ~]$ screenfetch
           /:-------------:\          cs@lh
        :-------------------::        OS: Fedora 34 ThirtyFour
      :-----------/shhOHbmp---:\      Kernel: x86_64 Linux 5.13.14-200.fc34.x86_64
    /-----------omMMMNNNMMD  ---:     Uptime: 16m
   :-----------sMMMMNMNMP.    ---:    Packages: 2628
  :-----------:MMMdP-------    ---\   Shell: bash 5.1.0
 ,------------:MMMd--------    ---:   Resolution: 3000x1920
 :------------:MMMd-------    .---:   DE: Cinnamon 5.0.5
 :----    oNMMMMMMMMMNho     .----:   WM: Muffin
 :--     .+shhhMMMmhhy++   .------/   WM Theme: Mint-Y-Dark-Aqua (Mint-Y-Dark)
 :-    -------:MMMd--------------:    GTK Theme: Mint-Y-Dark-Aqua [GTK2/3]
 :-   --------/MMMd-------------;     Icon Theme: Mint-Y-Aqua
 :-    ------/hMMMy------------:      Font: Noto Sans 9
 :-- :dMNdhhdNMMNo------------;       Disk: 373G / 839G (45%)
 :---:sdNMMMMNds:------------:        CPU: 11th Gen Intel Core i7-1185G7 @ 8x 4.8GHz [54.0°C]
 **-----:://:-------------::          GPU: NVIDIA GeForce GTX 1650 with Max-Q Design**
 :---------------------://            RAM: 3920MiB / 15694MiB

Kind regards

The display setting there, and the next to last line of your screenfetch post clearly shows the nvidia driver is being used with the GeForce card.

To verify you might open the nvidia settings panel and look but to me that seems the nvidia is the one that is active. I don’t think the nvidia settings panel will open if the GPU is not active. The driver will always be loaded for the intel GPU even when it is not active.