Rpm - Nvidia driver on Fedora 34, seems to have issues

Hi everyone,

So previously I’ve had no issues at all with the fusion packaged nvidia driver, in the past I’ve used the propriety driver, the non-free nvidia driver, and even the fedora packaged driver, all worked without issues.

After upgrading to Fedora 34 the non-free-nvidia, and packaged nvidia driver no longer seem to work. Not a huge issue for me as I revert to my built in video driver, but there seems to be some issues with the current packaged driver.

I’m more than happy to help out with testing this as I’ve been through the rigmarole of working with Nvidia in the past. So is it better to open a bug report, or simply work with the team that packages the driver?

I have completely removed all all traces of the Nvidia driver and started from scratch, but the system always crashes, even when the driver is correctly loaded.

1 Like

This depends on whether there’s an issue with RPM Fusion’s packaging, or with the Nvidia driver itself (since RPM Fusion simply packages the driver Nvidia provide into an RPM to work well on Fedora systems)

If you are also seeing the issue with the Nvidia driver that Nvidia provides, the best thing to do would be to report it on their forums and help them fix it. If the Nvidia provided driver works, but the kmod packages from RPM Fusion do not, then it’s best to file a bug at RPM Fusion and help the maintainer fix it.

1 Like

Thanks for the advice, Ill do a propitiatory driver installation over the weekend to test this, then feed into RPM Fusion if necessary.

1 Like

Cold comfort probably but I’m using akmod-nvidia-465 and did not run into this on upgrading. Everything went smoothly.
It may depend on the exact video card I guess.

1 Like

if you are using cuda + nvidia drivers + xorg it doesn’t go smoothly.

It is under X…

$ rpm -qa ‘nvidia

okey then well you can see my post that I’ve just made:

You will see that’s not really a great result on my end

I have reconfirmed my tool’s compatibility with Fedora 34. Could you once try https://copr.fedorainfracloud.org/coprs/t0xic0der/nvidia-auto-installer-for-fedora/ on a fresh installation?

If I do a rpm search akmod-nvidia* I only get the following packages:

akmod-nvidia.x86_64 : Akmod package for nvidia kernel module(s)
akmod-nvidia-340xx.x86_64 : Akmod package for nvidia-340xx kernel module(s)
akmod-nvidia-390xx.x86_64 : Akmod package for nvidia-390xx kernel module(s)

The package I would use would be the nvidia 460 driver.
Nvidia akmod-nvidia.x86_64 seems to provide this, and everything installs correctly, but the system just locks up.

Anyway, ill do a proprietary install over the weekend and test the latest nvidia driver and feed back.

People using the nvidia cuda repository might need to re-issue a dnf module disable nvidia-driver to prevent the nvidia packaged driver to interfere with rpmfusion packaged driver.

As a reminder, please prefer the rpmfusion packaged driver, specially on Fedora as it’s better shaped, community maintained and will support updated kernels whenever fedora will migrate to newer kernel updates.

If any others kind of errors, please use a dedicated issue to bugzilla.rpmfusion.org with the archive generated by sudo nvidia-bug-report.sh attached in the ticket.

Thanks in advance, and please enjoy rpmfusion packaged nvidia driver on f34 (when really needed! , please consider using nouveau when possible).

1 Like

Do you handle the dnf module disable nvidia-driver to prevent the nvidia-cuda module to interfere ?

1 Like

I’m having the same problem after upgrading from Fedora 33 to Fedora 34. I don’t know if my problem is related to the new INTEL-MESA drivers but my Nvidia GPU seems not to be recognized anymore. When i try to lunch any game or application that use the “discrete graphic card” i receive this error:

MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

X Error of failed request:  GLXBadFBConfig
  Major opcode of failed request:  150 (GLX)
  Minor opcode of failed request:  0 ()
  Serial number of failed request:  311
  Current serial number in output stream:  311

Tried to check if is all ok with my drivers and seems it is though:

[user@localhost ~]$ lspci -k | grep -EA3 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
    Subsystem: Acer Incorporated [ALI] Device 0940
    Kernel driver in use: i915
    Kernel modules: i915
04:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 840M] (rev a2)
    Subsystem: Acer Incorporated [ALI] Device 0942
    Kernel driver in use: nouveau
    Kernel modules: nouveau

No I don’t. Would it be the right thing to do?

1 Like