Fedora 34 NVIDIA kernel module missing. Falling back to nouveau


I have tried installing nvidia drivers via gnome software, manually via terminal and nvidia auto installer script. Everything seems ok until final moments of reboot when I get a message that kernel module is missing. Nvidia X server settings app does not start when I try to run it. I did not have this problem with fedora 33, where drivers run smoothly. Is there anything I can try to make it work? I even tried installing fedora 33 and upgrading it to 34 but it did not work either. I would be glad to get some help with this issue.


1 Like

I’ve had good results using akmod-nvidia (from rpmfusion-nonfree repo). There have been no issues with upgrading over many Fedora releases. It automates the building of the kernel modules as each kernel is installed.
At worst I had to reboot after the module built and gdm didn’t start (but that was several years ago).

Thanks for the answer but I had tried this as well without positive results :frowning:

Sorry to hear that… it can be frustrating when things go south.
If you haven’t tried it … make sure you have removed all packages that have nvidia in the name and then install akmod-nvidia.
There is another post regarding problems with the nvidia driver which seems to be related to some third party packages (steam I think) and/or i686 libraries. If that is the case, removing these first and reinstalling later might help.

Here’s a checklist of things to try and see if they work.

  • Confirm if secure boot is turned off or not in your BIOS utility
  • Check the version of akmods package installed by running rpm -qa akmods
  • Run sudo akmods --force && sudo dracut --force to build the kernel modules

Let me know if they help. Please feel free to tag me with anything related to NVIDIA and I would try my best to be of assistance. :slight_smile:


Thanks, I have secure boot off in BIOS and those 2 commands You have suggested give such answer:

[thoma@fedora ~]$ rpm -qa akmods
[thoma@fedora ~]$ sudo akmods --force && sudo dracut --force
[sudo] hasło użytkownika thoma:
Checking kmods exist for 5.11.16-300.fc34.x86_64 [ OK ]
[thoma@fedora ~]$

Now rebooting to see if there is any change, fingers crossed :slight_smile:

Nope… the message Nvidia kernel module missing is gone now but fedora defaults to intel driver instead of nvidia. It’s a bit od a nuisance. Thanks for help anyway

Still cannot run nvidia MX150 chip on my system

1 Like

It means that the driver is working now. The default way of installation ensures that the Intel GPU is used by default and the NVIDIA GPU would be used on-demand whenever there is something which is executed on the discrete GPU, specifically. Please follow this guide How to Set Nvidia as Primary GPU on Optimus-based Laptops :: Fedora Docs to set NVIDIA as your primary rendering device for everything if you are running Fedora Workstation.

Yes, thanks, I have uninstalled drivers and followed the instructions of this guide to a certain point but then I got this from the info screen. Two intel drivers loaded instead of the nvidia / intel configuration… Any thoughts on this? Or is there something I do wrong? I would be glad to get some more help with this.


At least I do not get Nvidia kernel module missing / Falling back to novueau message

1 Like

Could you send an output of the command screenfetch please?

You need to install screenfetch first.

If PRIME configuration has been set right, you would find something like this.

Even I have a PRIME configuration enabled and that helps GNOME 40 run smooth.

Here it is! I hope it somewhat helps the case.

The output is very strange and remarks the fact that the drivers have not been properly installed, because if that would have been the case, you would have had two values for the GPU key - one marking for the integrated GPU and the other for the discrete GPU. The one value shown over here is that of the integrated GPU which signifies that the discrete GPU could not be successfully recognized.

Try right-clicking on applications on app drawer and see if there’s an option called “Launch using Discrete Graphics Card” listed there or not.

1 Like

Yes, indeed, I have that option

Hi. Same here…
Just installed F34 on fresh SSD, disabled secure boot before that.
Nvidia driver does not load when I installed akmod-nvidia.
And this is not the first time… I think I will try the nvidia propietary driver instead. Can’t remember if i EVER got the akmod-version working…
I admit, I don’t know much about kernel modules or compiling linux but somehow I usually manage to get the driver working. I even tried toxic coders install script, it told me all the packages were allready installed…

My SSD is encrypted with LUKS. When I choose linux kernel line from GRUB2, the password prompt for LUKS comes right after that. When nvidia driver isn’t loaded, the screen is just blank and I write my passowd there. Soon after i get the message “nvidia driver not loaded, falling back to nouveau” and then gnome40 login screen. Everything works without the nvidia driver… But I want to start playing some gamesand do stuff.
Also, uninstalling Steam before installing Nvidia drivers didn’t do anything for me. That’s why i decided to do a fresh install for Fedore34.

Are you (fedora developers) saying, that when installing akmod-nvidia from rpmfusion, the thing should just work?

I did some more magic now. I followed this and there are 2 extra steps:

grubby --update-kernel=ALL --args='nvidia-drm.modeset=1'

And: WaylandEnable=false in /etc/gdm/custom.conf

That did the trick for me now. Probaby the latter is more important.

1 Like

I can confirm having the same problem that changing the Windowing System on Fedora 34 from Wayland to X-org/X11 solves my issues with my NVIDIA Gpu. To do it follow this:


@buli, that means that the driver has been installed successfully and can be used for certain applications which can take advantage of better GPU performance. Try running 4K60 videos on a browser with and without a discrete graphics card and you would most likely see the difference.

@laamani, it might be the case where the drivers are installed but somehow fail to load up due to the fact that the kernel modules were not built. Could you please try the steps provided here https://discussion.fedoraproject.org/t/fedora-34-nvidia-kernel-module-missing-falling-back-to-nouveau/68831/5 and see if it works?

Also just like any other piece of software, akmod-nvidia might give you a hard time if it has not been installed correctly so I would suggest actively communicating issues and we’d certainly try to be of assistance. I do not work with RPM Fusion folks on this package but I do know how it works to be able to help.

Installing akmod-nvidia would automatically enable the command-line arguments that you specified of, on boot so I do not think that needs to be done explicitly. With recent releases, even PRIME configuration works just fine with Wayland so I doubt toggling Wayland would help. An RFE is in order, I think.