Fedora 34 NVIDIA kernel module missing. Falling back to nouveau

@t0xic0der , thanks for general help as my problem with kernel modules missing have been solved. One final step was to set x-org as my default windowing system as suggested by @leviathan. Now everything works as it should. Thank You all people. I can say I am a happy fedora 34 user now. See You again.

Glad to be of your assistance and to know that you love using Fedora 34. :slightly_smiling_face:

@ankursinha @hhlp @alciregi @augenauf @grumpey - We have a happy user here. :heart:


@t0xic0der Yeah
akdods --force && dracut --force
worked fine with no errors.
But the resolution for me too was to disable Wayland (enable xorg).

EDIT: I disabled Secure Boot also.

Please stick to X11 if that is what works for you.

I would have to investigate more as to why Wayland does not work even when I am running it just fine with a PRIME config. I will try to keep you posted with the outcomes.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.