NVIDIA Auto Installer for Fedora now works with Fedora 34

The v0.3.5 release of NVIDIA Auto Installer for Fedora has now been tested and confirmed to be working on Fedora 34. With this release, the executable binaries have been phased out in favor for a much convenient packaging on COPR.

Simply execute the following commands in succession to install the tool.

# dnf install dnf-plugins-core -y
# dnf copr enable t0xic0der/nvidia-auto-installer-for-fedora -y
# dnf install nvautoinstall -y


Please report any issues that you have here and feel free to tag me with any issues related to NVIDIA installations on Ask Fedora. I would be glad to assist. :slight_smile:


I ran the --compat option first and everything checked out so then I ran the --driver option. Too bad this doesn’t work for me. I received the error of, “[ ✗ ] RPM Fusion repository for Proprietary NVIDIA Driver was not detected”.

1 Like

Never mind, it is now working! You have to give it the sudo nvautoinstall --rpmadd BEFORE running the --driver option

1 Like

Glad to know that it ended up working for you. :grinning_face_with_smiling_eyes:

It does not work for legacy-cards (e.g. nvidia 340.xx driver), it works fine with the latest nvidia driver for newer cards. This should be mentioned.


Hi @heliosstyx,

This seems to have been specified in the “Note” section of the GitHub repo’s README.md file (GitHub - t0xic0der/nvidia-auto-installer-for-fedora-linux: A CLI tool which lets you install proprietary NVIDIA drivers and much more easily on Fedora Linux (32 or above and Rawhide)) and here too (https://copr.fedorainfracloud.org/coprs/t0xic0der/nvidia-auto-installer-for-fedora/) - that it has only been tested to be working on 9XX/10XX/20XX series cards.

This should work on Rocky Linux also… yes? I need to test that out. RC1 has been released; I’m just waiting on the GM to give it a spin.

1 Like

I am not very sure if it would work, for I have not tested it there.

Plus, installing it might not be possible as I have built support for the following distributions only.

Ref Build 2203357 in t0xic0der/nvidia-auto-installer-for-fedora

I guess I’m doing this right, I have a GTX 750 Series Card and am one-by-one copy / pasting the commands. When I typed sudo nvautoinstall --plcuda I installed 5 gigs of data. If i want to remove / uninstall this, what is the proper way to go about this? Would it just be sudo nvautoremove --plcuda

Also, does the update center automatically update all this stuff? Or do I have to re-update and run commands manually later?

This is awesome, thanks!!

1 Like


This tool has been tested only on 9XX/10XX/20XX cards so I am unable to state for certain that this would work. Also, the tool (as of now) does not provide a way to uninstall - so please use this command to uninstall cuda.

dnf remove cuda

The update center would be able to automatically update the packages installed as the tool is simply a wrapper on DNF and other such utilities - attempting to streamline the process of installing the drivers and other such NVIDIA utilities.

error post

Thank you for this!

I was on Intel mesa before running this script, you made installing nvidia drivers super easy

gns3@gns3:~]$ screenfetch
/:-------------:\ gns3@gns3
:-------------------:: OS: Fedora 34 ThirtyFour
:-----------/shhOHbmp—:\ Kernel: x86_64 Linux 5.13.9-200.fc34.x86_64
/-----------omMMMNNNMMD —: Uptime: 2m
:-----------sMMMMNMNMP. —: Packages: 2326
:-----------:MMMdP------- —\ Shell: bash 5.1.0
,------------:MMMd-------- —: Resolution: 8320x1440
:------------:MMMd------- .—: DE: GNOME 40.0
:---- oNMMMMMMMMMNho .----: WM: Mutter
:-- .+shhhMMMmhhy++ .------/ WM Theme:
:- -------:MMMd--------------: GTK Theme: Adwaita-dark [GTK2/3]
:- --------/MMMd-------------; Icon Theme: Adwaita
:- ------/hMMMy------------: Font: Cantarell 11
:-- :dMNdhhdNMMNo------------; Disk: 47G / 933G (5%)
:—:sdNMMMMNds:------------: CPU: Intel Core i7-8750H @ 12x 4.1GHz [66.0°C]
:------:://:-------------:: GPU: NVIDIA GeForce GTX 1070 with Max-Q Design <<<<<<<<<<<<<<<<<
:---------------------:// RAM: 2047MiB / 31773MiB

1 Like

Glad to know it was of help to you. :slight_smile:

Hi @t0xic0der, how do I check that it is installed correctly or is it working?
I can only check it like this (attached image), but I don’t know if it is really working. 05a475f4786c849c8293e3a95e917975cfc274d9.png

If you install inxi then run “inxi -Gxx” the output will show you if the nvidia driver is in use or its FOSS alternate nouveau.

Also using “lsmod | grep nvidia” will list all the nvidia modules that are active. If the output of this is blank then the nvidia drivers are not loaded.

Thank you, the output of “lsmod | grep nvidia” is blank, in that case what should I do? Thank you very much.

This image is running inxi -g

Great job! Maybe it’s a slightly different issue. Unfortunately, I ran into issues of not finding xorg-x11-drv-nvidia.
When I run sudo nvautoinstall --driver

I got 69d9697c3e00619418f0c1fd285cd8f6a401ea94.png

Then I tried to search xorg-x11-drv-nvidia, it doesn’t have the latest version xorg-x11-drv-nvidia-470 that listed in https://fedora.pkgs.org/34/rpmfusion-nonfree-updates-x86_64/xorg-x11-drv-nvidia-470.63.01-3.fc34.x86_64.rpm.html.

I have updated dnf and non-free repos.

Any comments are much appreciated!

@kayajooks it seems you do not have the nvidia driver installed.

@fredfung It looks the same.

I would do the following, since I am more of hands-on type admin.

  1. Make sure the rpmfusion repos are installed as in Configuration - RPM Fusion
  2. do a full update so you have the latest kernel, then reboot
sudo dnf update -y
  1. install (or reinstall) the drivers.
sudo dnf install akmod-nvidia nvidia* xorg-x11-drv-nvidia*470* --disablerepo=fedora,updates --exclude=nvidia*390*
  1. reboot again so the driver gets loaded

It now should be working with the nvidia driver and “lsmod | grep nvidia” should show the modules in use.

This is all that should need be done. However, if you are using a laptop and are having issues with the display & external monitor not showing correctly then that seems to be fixed by copying /usr/share/X11/xorg.conf.d/nvidia.conf to /etc/X11/xorg.conf.d/nvidia.conf and once again restarting.

Hi @computersavvy , I did everything you recommend but still does not work is there any way to validate if my graphics card is compatible I have a NVIDIA® GeForce® GTX 1650 With Max-Q Design, 4GB GDDR6 in a notebook MSI Prestige 15 A11SCX.

When I reboot I get the message shown in the following image:

I executed some commands indicated by @t0xic0der in the following link

I use Fedora with Cinnamon not Gnome.

1 Like