Nothing detected on USB ports after resuming from suspend

I’ve got an AMD based mini PC with a Ryzen5 5600u that happily ran Fedora 39 since its release. I got adventurous and upgraded to Fedora 40 with Plasma 6 as I wanted to try it. I’ve got an odd issue that I cannot seem to resolve. When the PC has been asleep for an extended period my logitech 720 mouse and Steel Series keyboard are no longer functional when it resumes from sleep. Its as if the USB ports no longer detect them. Odd thing is the USB ports do have power as the RGB lighting works on the keyboard. I have already tried disabling hibernation mode but this doesn’t seem to fix it. The only way I can fix the issue is to reboot the PC and then all works normally. I had the same problem with KDE Neon so I don’t believe it to be distro specific. Any ideas on how to fix this? I’ve seen various posts on forums indicating this has been an issue with AMD based machines for a few years now. I will add it just sleeps for 30 minutes or so things resume after suspend normally. Its when its asleep for hours that I lose the USB ports, the only way to even wake the computer is to hit the power button.

Solved, here is the fix for others having this issue.

/etc/systemd/sleep.conf

AllowHibernation=no
AllowHybridSleep=no
AllowSuspendThenHibernate=no

Sorry to be picky, but there is a difference between a solution and a fix.
You fixed your problem by disabling hibernation. That is a mitigation, but not a solution to the actual problem.
(But thank you for sharing anyway.)

2 Likes

Added suspend-resume, usb

Are you using TLP maybe?

This appears to be a kernel bug with AMD machines as I have the same problem across multiple distros. The same workaround works for all of them

Are you running 6.8.4 yet?

Yes, does that fix it?

It corrected some similar issues.

It would be nice to have a couple additional categories: 1) interim “solutions” like workarounds that aren’t complete solutions but are based on an understanding of the issue and make a broken system usable with reduced functionality, and 2) non-solutions like switching to another distro before doing the work needed to understand a problem.

Great thanks, I’ll test it when I clean install Fedora 40 when its released

1 Like

on 6.8.6-200 and this issue still exists, just did a quick test after updating the kernel, suspended system (x570/5900x/64gb/6900xt) and after a short suspend I was able to wake the system, but lost my mouse yet had keyboard. I’ve had this issue before on 36 or 37 so it’s not new, just seemed to get reintroduced.