Silverblue does not wake up USB ports after suspend

Hello All,

I’m running Fedora Silverblue up to date on a desktop and have been having an issue for at least a few months now.

If I enable suspend in the power settings, the system seems to power off almost all USB ports (Except the front one of the chassis).
This makes it impossible to wake-up the system unless I connect a keyboard to the front USB port.
And even once I login with that keyboard, the remaining USB ports never wake up, even If I disconnect and connect them again.

I ended-up having to completely disable suspend.
I did some digging online on how to keep USB devices always active but it seem it implies modifying files that are read-only in silverblue, and on top of that, it kinda feels like I shouldn’t have to hack my way around this and should work Out of the box.

The system suspends and powers back on just fine in windows, and I double checked the BIOS settings already.

Is anyone experiencing a similar issue?
How did you work around it?

Motherboard is Gigabyte aorus master trx40 (I think), it has a Threadripper 3something

Thanks!

This looks like a kernel issue. Can you try to reproduce with a Fedora Workstation Live system?
A kernel bug report in Fedora Bugzilla might also be a good place to start.

It might be related to my problem.

Looks like I’ll be filing a bug.

I rather not install Fedora Workstation in parallel as I tried it before and had to do some manual edits in the EFI partition to be able to boot back to Silverblue.

In my case, gnome respects the auto-suspend setting, usb ports just stay dead when it wakes up.

Thanks,

My problem seems to be caused by a bad BIOS. You might want to check if yours is up to date.

I wonder if this is related to a recent issue I had with an integrated Wacom tablet on my laptop. Essentially my BIOS was set to “Linux” or s3 suspend, but s3 suspend support isnt well tested on some hardware because it’s not supported in Windows… the Windows code path is better tested. Windows suspend uses s2 suspend… so if you switch your suspend level in your bios from Linux to Windows it might fix the issue because you won’t be using s3 anymore just s2.

For more info on this see

It’s a long shot but I wonder if it could help.

Hi,

If I disable S3 in the BIOS, it suspends and immediately wakes up, a different issue aparently.,