Automatic suspend is OFF but it still suspends

The problem started after I upgraded from Silverblue 32 to 33.
It’s a desktop.
It always suspends when it is inactive for a while or with the screen locked or user the logged.
In Settings, Automatic Suspend is OFF.
I have to press all keyboard keys and mouse buttons to wake it. Sometimes it resumes from suspend but mostly it doesn’t and I have to reboot it.

This does not look like a Silverblue specific issue and it looks like you there are two bugs: GNOME not respecting the automatic suspend option and the computer not correctly waking up from sleep. Can you report both bugs in the Fedora Bugzilla? The first one should be filed for GNOME and the second one for the kernel.

I have also generally had issues with my ThinkPad E585 coming back from suspension but I mostly chalk that up to it being an early Ryzen release in a model of computer that Lenovo doesn’t have a lot of interest in supporting as well. Also it has never worked 100% with any distro or DE.

What model of computer do you have?

It’s a desktop with Ryzen 7 3700x and Radeon RX 5700 XT.
I didn’t have any problems in Silverblue 32. They started only in 33.