F34 not recovering from suspend mode

Hi. Yes, I checked other entries but not sure are related. It happens at random. I upgraded from F33 and start noticing that, every one or two days, the system does not recover from suspend, so I am forced to reboot. Can anyone point me to other reports/solutions regarding this issue?
Thanks in advance.

Update: after posting, I think found the reason for this behavior. Since upgrading to F34 beta, I noticed updates were not so frequent and a particular package was not updated (a library related to “Freedesktop” something). I verified the repos via the Software app and found those for updates-testing were actually disabled. Given that F34 is still officially beta, I found that setting odd and enabled the updates-testing repos. Received and applied a bunch of updates.
So, I think this is the culprit. If I still get hit, I will report back. Thanks for your attention.


just in my case…
Beta and regular installation or upgrade installation may be different.

Once again, thank you to the many people who participated in the preparation for F34.

[ The upgrade is in progress around the dawn of this day. It works really well without any problems. Applicable equipment HP notebook, Dell server, Intel Desktop (including GPU) two management equipment has been completed, and there are no abnormal symptoms. ]

notebook…fine and good work…F34 Server with KDE! Have a nice day!

Yes, thank you. I guess I need to disable the testing repos, now that F34 is final

1 Like

Sadly, the issue is still here. I looked into var/log for any hint but found nothing I could understand. I will need to shut down every evening to avoid this problem for the time being.

Update: Actually, it got worse, since the problem is happening more frequent. Although I did open my workstation to clean it a month ago, I don’t suspect a hardware issue. I went to settings and turned off Automatic Suspend. Curiously, I discovered a new Power Mode option set at “Balanced Power” that I switched to “Performance”. I also turned off a couple of shell extensions for the time being. I will suspend the workstation manually (as I used to do), and see what happens.

thanks for the awesome information.

@boricua Might not be your issue but when I had a similar issue with my F34 install I found that it was gnome extension that was causing the issue. I peeled them back one by one until it successfully resumed.

Thanks, Steve. In my case, it seems to be hardware-related after all. When I turn off the machine, sometimes I need to turn off and on several times before I get it to boot. This is weird.

Is there any firmware updates available for it via the manufacturer or fwupdate? It might be as simple as BIOS update…

Hmmm. I suspect you may be right. However, running fwupdmgr shows an issue:

[francisco@principal ~]$ sudo fwupdmgr
[sudo] password for francisco:
WARNING: Firmware can not be updated in legacy BIOS mode
See PluginFlag:legacy bios · fwupd/fwupd Wiki · GitHub for more information.
Command not found

It appears I will need to reinstall Fedora in order to correct this limitation and allow BIOS updates.

I consulted a local guru and his findings point to a buggy kernel module. This bug has been around for some years, hitting many Linux distros and not just Fedora. It seems my workstation is not actually shutting down. My plan is to switch from the traditional workstation to Silverblue (a switch I was planning to do anyway, but now faster). And see how it goes. Thanks for all the attention and support.

Keep us updated as we have this issue frequently.


You may need to try and customise according the that recommendation if you feel confident read through this article


To be honest most of the time I have seen this issue it simply won’t work and cannot be fixed.

Linux as a desktop I see has two main drawbacks power management (especially on mobile devices like laptops) and printer/fax/scanner drivers. They are always hit and miss in my years of experience

I installed a brand new SSD and installed Fedora 34 Silverblue, hoping to see a change. Same thing happened. I turned on automatic suspend after half an hour, and then found the workstation running but unresponsive. I did noticed something different. After forcing a shutdown, the workstation turned on at first try. I noticed this the last time I turned off/on while still using F34 traditional and now also with Silverblue. Previously, I have to push the button from 3 to 10 times, before getting a real start.

Indeed, nobody seems to have a solution to this issue at present. In fact all our desktops don’t wake up and they run Fedora, and a range of debian systems.

It is an ongoing issue.

Best workaround is to disable sleep and hibernate mode. Set screen and standby to “never”.

and dont ever put them to sleep

I don’t ever have a problem with the screen turning off and the system locking then unlocking and logging back in. I leave the PC processing things in the background and don’t use suspend or hibernate.

I spoke too soon. Silverblue shows the same behavior as regular Fedora. I needed to push the button no less than 5 times before actually getting a boot up. I also noticed more than usual kernel updates, so I hope this will be solved soon.

Important update. It was a hardware issue. My workstation’s power supply was dying in a manner I have not seen before. After the switch to a new power supply, suspend is working, although not as consistent as it should.


Hi there, so I am still having this issue for two years, so is it possibly the power supply fixed your issue. I would have thought it would have been the firmware in the motherboard.

Did you get the issue to vanish?

Yes, absolutely. Everything has been working just fine, even with F35 Silverblue beta.

I have an 11 year old power supply, and I have the same issue as you had. My system will not recover from standby mode.

I know that this issue happens on all Linux ditros but not on windows 7.

So its hard for me to justify swapping out a new power supply but if it worked for you in tempted.

Indeed, I had never seen a power supply failing like that. They usually simply burn and that’s it. But with the new one no issues so far.

1 Like