Noisy sound on laptop when moving mouse

recently installed fedora 37 on my lenovo legion laptop
and when I move the mouse, or using the touch pad, i hear some noisy sound only when the cursor is moving on the screen, like a scratch sound.
Tried to close all programs, but is still there. removed external mouse, using only touchpad, still there
Tried other linux is ok, windows is ok
Maybe some drivers missing? any help? thanks.
f37 with mate desktop, laptop lenovo legion 5

Welcome to ask.fedora @chroot

Please if you not had time yet, read the #start-here section to see what kind of Information is useful that we can help you.

First thing I propose you is to update your system and then give us a inxi -Fzx and post the output as </> pre formatted text here.

I use frequently also the mate desktop and I remember to get this issue.
To help you debug it would be good to know if you also use a wireless Mouse from Logitech?

Just let us find out. For this wee need more info’s as explained above.

My guess would be graphic drivers or just a firmware is missing, that it has to do with the movement of the cursor/mouse. Or just a codec who is not installed by default.

Thanks for your reply
strange that now is not doing any noise …

and yes is a logitech m560 mouse, but even without plugged, the touchpad also was noisy

  Kernel: 6.0.10-300.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37 Desktop: MATE v: 1.26.0 Distro: Fedora release 37 (Thirty
  Type: Laptop System: LENOVO product: 82B3 v: Lenovo Legion 5 17IMH05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <superuser required>
    UEFI: LENOVO v: EFCN48WW date: 01/13/2021
  ID-1: BAT0 charge: 63.3 Wh (85.1%) condition: 74.4/80.0 Wh (93.0%)
    volts: 16.3 min: 15.4 model: Celxpert L19C4PC2 status: discharging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M560
    charge: 55% (should be ignored) status: discharging
  Info: quad core model: Intel Core i5-10300H bits: 64 type: MT MCP
    arch: Comet Lake rev: 2 cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 2075 high: 2500 min/max: 800/4500 cores: 1: 2500 2: 2500
    3: 2500 4: 2500 5: 800 6: 2500 7: 2500 8: 800 bogomips: 39999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA TU117M vendor: Lenovo driver: nvidia v: 520.56.06
    arch: Turing bus-ID: 01:00.0
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-6:2
  Display: x11 server: X.Org v: 1.20.14 driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia,nvidia-nvswitch
    resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce GTX
    1650/PCIe/SSE2 direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3
  Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel
    bus-ID: 01:00.1
  Sound API: ALSA v: k6.0.10-300.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.61 running: yes
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 07:00.0
  IF: enp7s0 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:4
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
  Local Storage: total: 476.94 GiB used: 8.9 GiB (1.9%)
  ID-1: /dev/nvme0n1 vendor: Lenovo model: UMIS RPITJ512VME2OWD
    size: 476.94 GiB temp: 32.9 C
  ID-1: / size: 96.66 GiB used: 8.64 GiB (8.9%) fs: btrfs dev: /dev/nvme0n1p7
  ID-2: /boot size: 973.4 MiB used: 219.6 MiB (22.6%) fs: ext4
    dev: /dev/nvme0n1p6
  ID-3: /boot/efi size: 96 MiB used: 47.9 MiB (49.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 96.66 GiB used: 8.64 GiB (8.9%) fs: btrfs
    dev: /dev/nvme0n1p7
  ID-1: swap-1 type: zram size: 7.67 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 41.0 C pch: 39.0 C mobo: N/A gpu: nvidia
    temp: 39 C
  Fan Speeds (RPM): N/A
  Processes: 269 Uptime: 7m Memory: 7.67 GiB used: 1.57 GiB (20.5%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.2.1 Packages: N/A
  note: see --rpm Shell: Bash v: 5.2.9 inxi: 3.3.23

Ok, I see the mouse has a frequency of 2.4 Mhz. How are you connected to the network when the noise is there … with WiFi? Maybe Bluetooth on? This could give interference’s.

Next time when you get the noise you should check:

Again Inxi -Fzxto see if you have a different driver/kernel etc. in use.
Is WiFi / Bluetooth on/off and are you using Earbuds / Headphones while hearing this noise?
Which WiFi (if on) Frequency you use 2.4 or 5 Ghz ?

When I check my inxi we do have the audio diver in common.
This about Bluetooth I mentioned because WiFi and Bluetooth share sometimes the chip.

thanks , i will do

Hi again
figured out, the problem is when the touchpad is active, when i disable it from Fn + f10, no sound at all

i did some search dnf search touchpad but nothing to install

any ideas? thanks